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Chapter 1   New Features in NanoScope 
v6.13 Software
. This 

is 
1.1 Newly Supported Hardware

NanoScope v6.13 supports hardware that was formerly supported only by NanoScope v5.30
includes:

• Torsion (TRmode).

• Electrochemistry including the Universal Bipotentiostat.

• EnviroScope (not including Auto Programs/recipes).

• Dimension Hybrid XYZ Scanning Probe Microscope Head.

See the appropriate manuals, Support Note 402 TRmode, Support Note 390 Universal 
Bipotentiostat, Electrochemical SPM Manual, EnviroScope Manual and Support Note 394 
Dimension Hybrid XYZ Scanning Probe Microscope Head for details. 

1.2 Windows XP Support

NanoScope v6.13 runs on Windows XP in addition to Windows NT and Windows 2000.

1.3 Additional New Features

Additional new features, described in the NanoScope v6.13 release notes, are included in th
manual. These include:

• Single and batch Bitmap and jpeg export.

• Programmed move.

• Step and width analysis functions.
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Chapter 2   Getting Started with 
NanoScope v6.13 Software
ks 

 

The focus of this manual is the NanoScope software version 6.13. It is a reference to the tas
related to your NanoScope system. The material provides an overview (i.e., theory and 
applications), procedures, interface definitions and optimization tips.

Refer to the following sections to begin to understand the NanoScope software:

• Installing the NanoScope Software: Section 2.1

• Getting to Know the NanoScope Software: Section 2.2

• Setting up the Workspace Section 2.3

• Quick Guide to a 4K Point Image: Section 2.4

• Using Online Help: Section 2.5

• Technical Support at Veeco: Section 2.6

2.1 Installing the NanoScope Software

2.1.1 System Requirements

The 6.13 version of software requires the following:

• A minimum computer configuration of 1.7GHz (2.4GHz recommended)

• 512MB RAM (1GB recommended)

• G450 Video (G550 Video recommended)

CAUTION: Contact Veeco Technical Support (see Contact Information  Section 
2.6.2) before attempting to increase the RAM of your system. Failure
to do so could cause irreparable damage to your system.
Rev. D Nanoscope Software 6.13 User Guide 3
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2.1.2 Before You Install

1. If you are upgrading from a previous version of NanoScope, ensure you are starting w
working version. The settings from the working version will be used for the new version

2. Note that some of the installation screen views may not appear, or may appear slightly
different, depending on your particular system configuration.

3. Make sure you have downloaded and installed NS Toolbox. This is available on the 
NanoScope 6.13 CD or from the Veeco FTP site (contact Veeco for more information).

4. Make sure you are logged in as Administrator on the local workstation.

2.1.3 NanoScope 6.13 Installation

Note: Most systems are configured on the microscopes prior to delivery.

1. Insert the NanoScope 6.13 CD-ROM in your CD drive, open the CD-ROM files, open t
v613 folder, and select the Setup.exe icon. 

If you do not have Administrator privileges on your workstation, a WARNING will appear on t
screen and installation will discontinue (see Figure 2.1a).

Figure 2.1a   Administrator Warning

CAUTION: Ensure you have backed up all critical data onto external media bef
installing the NanoScope 6.13 software.
Nanoscope Software 6.13 User Guide Rev. D
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2. The Welcome to NanoScope 6 dialog box will open (see Figure 2.1b). Click NEXT .

Figure 2.1b   Welcome to NanoScope 6 Dialog Box

3. After choosing a destination location (see Figure 2.1c) click NEXT .

Figure 2.1c   Destination Location Dialog Box
Rev. D Nanoscope Software 6.13 User Guide 5
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4. The Installation Type dialog box will open (see Figure 2.1d).

Figure 2.1d   Installation Type Dialog Box

5. Select the features you wish to install:

Figure 2.1e   Select Features Dialog Box
Nanoscope Software 6.13 User Guide Rev. D



Getting Started with NanoScope v6.13 Software
Installing the NanoScope Software

 
6. The Install Shield Wizard will display system configuration and recommendations (see
Figure 2.1f). Click CANCEL  if you wish to change your configuration. Click NEXT  to 
proceed.

Figure 2.1f   System configuration and Recommendations Dialog Box

7. The Ready to Install dialog box will display:

Figure 2.1g   Ready to Install Dialog Box
Rev. D Nanoscope Software 6.13 User Guide 7
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8. Installation of the NanoScope V6.13 software will then continue. A progress box, show
Figure 2.1h, appears:

Figure 2.1h   Progress Dialog Box 

9. When the NanoScope V6.13 installation is complete, the following dialog box will appe

Figure 2.1i   Installation Complete Dialog Box

10. Click FINISH  to complete the installation.
Nanoscope Software 6.13 User Guide Rev. D
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2.2 Getting to Know the NanoScope Software

Start the NanoScope software by double-clicking on the desktop shortcut labeled NanoScope 6.13.

2.2.1 Software Interface

The NanoScope software contains two modes of operation: Realtime (i.e., all operations related to
controlling of the microscope) and Image Processing or Offline (i.e., analysis and modification of
captured images). In previous versions of NanoScope software, these modes were separate
environments. With version 6.13, both work environments have been combined into a “works

2.2.2 What is a Workspace?

A workspace is a configuration of views and parameters in the NanoScope software. Within 
workspace window, the user configures a hierarchy of commands (i.e., nodes) for running th
microscope and processing images. Auto programs are run in the order that commands are 
configured. 

The behavior and appearance of the workspace window may be controlled using the Workspace > 
Preferences menu or by right-clicking in the workspace window.

Figure 2.2a   Workspace Nodes

Parent
Node

Child
Node
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Nodes

The top level node is known as the parent node and each node underneath is known as a child node 
(see Figure 2.2a). Parent nodes are usually the name for the microscope mode (e.g., Realtime
file name of an image within the workspace. Parent nodes are the higher level nodes for auto
programs. Child nodes, also known as “views,” are typically associated with a window that is
to carry out an analysis, image processing, or Realtime control function of the software.

Each node may be renamed, deleted and grouped. Node names may be preceded by an ico
lines indicating the relative positions of nodes in the hierarchy. 

2.2.3 The Main Screen Elements

Start the NanoScope Software

Complete the following to open the NanoScope software: 

1. Double-click the desktop shortcut labeled NanoScope 6.13. 

2. The default screen appears with menu items (File, View, Help, etc.), a blank workspace and
a toolbar (see Figure 2.2b).

Note: Select File > Open Workspace to open a previously created workspace file.

Workspace Window The left pane in the client window for viewing and configuring a 
series of views.

Client Window A central window for viewing all Realtime graphical displays, input 
parameters, results parameters and graphs.

Menu Bar A group of items for executing commands or viewing files.

Toolbar A group of icons for executing commands or viewing dialog boxes 
to configure input parameters.

Status Bar A read only list that displays the stage X, Y, Z coordinates and 
enabled functions (e.g., Capture: On).

RT Status Window A dockable window in the client window displaying information 
about the sample during Realtime.

Browse Window A dockable window in the client window for browsing files. Avail-
able in list or thumbnail format. 

Help Window A dockable window in the client window for displaying the Help 
screen.
Nanoscope Software 6.13 User Guide Rev. D
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Figure 2.2b   Screen Elements

Functions Menu

The Functions menu is accessed by right-clicking on a parent node (i.e., Realtime or a filenam
includes specific elements for viewing multiple windows, renaming views, grouping views, an
adding and deleting views. This menu also includes the command for running an Auto Progr
(i.e., Run AutoProgram) where the image processing commands may be run in a series on 
multiple images and results may be saved in a data file (see Figure 2.2c). 

Figure 2.2c   Functions Menu

Menu Bar

Toolbar

Workspace
Name

Workspace
Window

Status Bar
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 Menu Items

Add View Accesses a submenu of Realtime or offline commands.

Add Group Adds a Group node to the workspace for creating a defined set of
commands. 

Delete Deletes the currently selected node in the workspace. If changes
were made, a prompt appears to save the view.

Delete Sub Items Deletes the items listed under the currently selected node in the 
workspace. If changes were made, a prompt appears to save the
view.

Change Title Allows for the selected view title to be changed.

Permit Multiple Views Selecting this item allows for multiple views to appear in the clien
window (see Figure 2.2d).

Assign File TBD

Create Auto Program Allows you to create a new Auto Program based on analysis done
on a node. 

Edit AP Attributes If the currently selected node is in Auto Program, this parameter 
allows you to edit the Auto Program properties.

Run Auto Program Accesses the Auto Program Results view to run the selected ima
processing commands. 
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Figure 2.2d   Permit Multiple Views

Functions Submenu

The Functions submenu allows for adding new views to the workspace in the Add View command 
(see Figure 2.2e). 

Figure 2.2e   Realtime Workspace Functions Submenu

Meter
View

Scan
View

Navigate
View
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Functions Submenu Items

The Add View submenu includes commands for running the microscope, analyzing and repo
Selecting a command adds the item name and icon as a new child node to the workspace w
Click on a node to invoke the view in the client window. 

Depending upon the microscope type and mode (i.e., Realtime, Image Processing and Profi
each workspace has unique commands in the Add View submenu. For the Realtime functions Add 
View submenu, see Figure 2.2e. For more detailed descriptions about the views, see Chapter 3.

Quick Key Commands

Many commands have quick key commands (series of keys to enter in place of using the mous
You can open menus, access panels and execute commands with the keys or combination o
keystrokes. In the NanoScope software, the quick keys are designated by an underlined letter in 
the command name (e.g., R is the quick key in Realtime). 

To activate a quick key command, press the Alt  button then the quick key, or select the command
with the mouse and press the indicated quick key. 

Quick keys only apply when in an active box, menu, panel or window that is currently visible on 
the screen. Active panels are designated in color with a highlight on the panel title or with a he
frame around the panel.

2.2.4 Menu Bar Items

The initial menu bar includes: File, View and Help to begin the process of initializing and opening
files in the client window. Once a workspace is open an expanded toolbar exists for running 
configuring the microscope to scan or process images.

The menu items include:

• File—Accesses menu selections for opening, saving and printing files and docume

• View—Accesses menu selections allowing to choose display properties.

• Format—Accesses menu selections for modifying NanoScope files.

• Realtime—Accesses menu selections to administer commands during data collect

• Acquire—Accesses all Realtime Views.

• Analyze—Accesses all Offline Views.

• Tools—Accesses menu items for selecting and calibrating various settings.

• Window—Accesses menu selections for arranging windows.
Nanoscope Software 6.13 User Guide Rev. D
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• Help—Accesses menu items for initializing and displaying the help screen, a Bug 
Report dialog box to submit bugs/requests to Veeco, and NanoScope information a
your system.

2.2.5 Cursor Types

Within captured images, it may be necessary to do analysis or modification on a selected are
exclude this area from the analysis. Cursors allow for specifying this information.

The cursor types are as follows:

• Lines—Selecting specific data (e.g., lengths of features or sectioning features) alon
line.

• Boxes—Selecting specific areas on the display for including or excluding data.

• Grid Markers —Horizontal or vertical line cursors within histograms and spectrum 
graphs for choosing data ranges or making measurements. 

Using a Slider Cursor

In a graph or histogram, position the mouse with in the blank area between the axis and the e
the graph and drag the slider along the graph to position the cursor. The mouse cursor will c

to .

Positioning a Line or Box Cursor

• Click and drag the image to draw a line or box cursor. 

• To resize an existing line or box cursor, click and drag on a corner edge or end of 
object. Cursor will change to  or .

• To move an existing object, click and drag the center of the object to the desired 
location. The cursor will change to .
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2.3 Setting up the Workspace

2.3.1 Create or Open a Workspace

1. A workspace can be opened or created by selecting the following:

• File > New Workspace.

• File > Open Workspace and browse to open an existing workspace.

• File > Select the Workspace Name from the Recent files list.

Note: A new blank space will automatically display when version 6.13 is opened.

2. To begin Realtime operations, open a Realtime node. Select Realtime > Start Realtime or 
click the NanoScope icon.

A Realtime mode appears in the workspace, along with a dialog box allowing you to add view
the Realtime node.

2.3.2 Add Views and Configure the Workspace

1. Position the mouse on the Realtime icon and right-click to view the functions menu (see 
Figure 2.3a).

2. If one of the views (Scan-Single, Scan-Dual, or Scan-Triple) does not appear 
automatically, in the functions menu, select Add View and one of the scan views or click the
Scan button.

3.  Add the following views to your workspace to set up the hardware for scanning:

• Meter View—for verifying the laser signal on the cantilever. (If desired, the Realtim
Status Window can be opened in place of Meter View).

• Navigate View—for setting the tip to sample focus, locate tip and stage alignment (
present for MultiMode).

4. Customize your workspace with any additional views using the same procedure as in Step 2.

Note: In the Functions menu, select Permit Multiple Views  for allowing several 
windows to display.
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2.3.3 Multiple Users using NanoScope

The NanoScope computer can save multiple user preferences/settings in the computer regis
Once a user sets up an account on the computer, several settings are automatically saved fo
user. These settings include:

• Previous image file type

• Previous directories

• Browse window settings

• Option to disable video while scanning

• Section View results to display

• Location of Abort dialog box

• Review curve settings

• Force Filter settings

• Help settings

• Script directory

• Track ball on

• Default Parameter dialog box location

• Point and Shoot View settings

• Sweep dialog box settings

• Workspace settings

• Image control settings

• Grid control settings

• Meter View control settings

• Color control settings

• Z center control settings
Rev. D Nanoscope Software 6.13 User Guide 17
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Figure 2.3a   New Realtime Screen
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2.4 Quick Guide to a 4K Point Image

The following procedures provide quick steps for using the NanoScope 6.13 software. Follow
steps to quickly scan a sample and then capture and analyze an image. Along the way, you’l
how the NanoScope 6.13 software works, learn some useful tricks, and find out how to learn
later.

If you have used the “classic” NanoScope software, you’ll see that the new interface is Micro
Windows-based.

This section is not intended to teach a new user how to run an AFM, but only to introduce 
experienced users to V6.x.

2.4.1 Starting the NanoScope Software

After the software installation is complete, you are ready to start the NanoScope software an
some views to the software workspace.

1. To start the NanoScope software, double-click the NanoScope 6.13 startup icon on the 
computer desktop. You will see the NanoScope software window (see Figure 2.4a), which 
can span one or two monitor displays. This large window will contain all the areas and v
you use to control the microscope and analyze your results.

Figure 2.4a   NanoScope Software Window

2. Notice the white area on the left side of the NanoScope software window. This white a
the “workspace.” This area acts as an organizer for operations you use in the software
including scanning and analysis. Each item in the workspace has a view window that le
set parameters, perform actions, or view results. The sequence of items in the workspa
important only for Auto Programs that use analysis functions.
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3. Select Tools > Select Microscope to open the Microscope Select dialog box.

Figure 2.4b   Microscope Select Dialog Box

In the Microscope Select dialog box:

a. You can add a new set of hardware configuration parameters by clicking New, or edit 
the parameters of the selected microscope by clicking Edit . The parameters include 
things such as the controller, extender, and vision system.

b. In the Equipment dialog box, choose the microscope you are using (see Figure 2.4c). If 
you are using a MultiMode AFM, select the scanner you plan to use (Scanner button). 

Note: Select the Advanced button to view all equipment parameters.

Figure 2.4c   Equipment Dialog Box
Nanoscope Software 6.13 User Guide Rev. D
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4. Click the yellow Realtime icon in the toolbar. This adds a “Realtime” group and a Scan 
View to the workspace. It may take a moment the first time Realtime is added. A dialog box 
(see Figure 2.4d) will appear giving you the option to add more views.

Figure 2.4d   Add Realtime Views Dialog Box

5. Right-click on Realtime in the workspace and select Permit Multiple Views  from the pop-
up menu. When this item is enabled (that is, has a check mark next to it), you can have
several views open at the same time.

Note: Areas in the NanoScope software window can be resized and moved to ma
easier for you to use. When you reopen the software, it will remember you
changes. Drag the edge of an area to resize it. Drag the title bar or double r
lines on an area to move it to another edge of the window or to make it a 
floating window. (In Microsoft Windows terminology, these areas are 
“dockable.”) Click the “X” in the upper-right corner to close an area. Use th
View, File, or Scan menu to open an area. For details about the areas of the
NanoScope software window, see Section 2.2.

If you are using a Dimension Series AFM, continue with the steps in Preparing a Dimension S
AFM for a Realtime Scan. If you are using a MultiMode AFM, skip to Scanning and Scan 
Parameters Section 2.4.4.

2.4.2 Preparing a Dimension Series AFM for a Realtime Scan

Once you’ve created the workspace, prepare the system to scan. This includes selecting the
operation mode, aligning the laser, adjusting the photodetector, locating the cantilever tip wit
optical microscope, and focusing the optical microscope on the surface. If you have not yet le
these procedures please refer to your Dimension Microscope Manual and/or SPM Training 
Notebook.

For details on using the Realtime Scan Views, see Chapter 3.
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1. Click the Scan group or one of the Scan views (Scan Single, Scan Double or Scan Triple) 
in the workspace to see one of the Scan Views. Set the Microscope mode parameter to 
Tapping or Contact.

2. Mount the probe into the cantilever holder

3. Mount the cantilever holder onto the end of the scanner head.

4. Align laser on cantilever.

5. Click Meter in the workspace or check View -> Real Time Status to see the Meter View. 
Turn the two screws on the side of the scanner to adjust the laser position in the 
photodetector. In the Meter View, the location of the red dot and the values at the bottom
the display change.

6. Click Navigate in the workspace to see the Navigate View. This view shows the video and 
stage controls. Activate the track ball by clicking on the Track ball  ON button inside the 
Navigate View.

7. Click the Locate Tip icon in the toolbar or the Locate Tip button within Navigate View. 
Using the two adjustment screws to the left of the optical objective of the microscope, c
the tip of the cantilever under the crosshairs.

8. Focus on the tip end of the cantilever either by using the trackball while holding down t
bottom-left button or by using the Optical Focus mouse controls. Click and hold the large 
arrow keys to move the focus up or down. The speed is controlled by the sliding bar or
typing a value from 0 to 100. Click OK  to set the focus and enter Focus Surface mode.

When you leave Locate Tip mode, the optics move to a focus position, typically 1mm below 
the tip. To set this, select Tools > Engage Settings > General > Motor.

9. Focus the optics on the sample surface using either the trackball or the Z Motor  arrows in 
the Navigate View. To use the track ball, set the trackball  to On, and roll the trackball up or 
down while holding down the bottom-left button. To use the Z Motor  arrows, click and hold 
them down. You can use the speed controls in the Z Motor  area to adjust the speed. This 
adjustment raises or lowers the Z stage on which the SPM and optics are mounted.

10. Move the x-y stage to align the desired location on the sample under the crosshairs eit
using the trackball without holding down any buttons or by using the XY Stage arrows in the 
Navigate View.

11. If you are using TappingMode, click the Tune icon. Check your parameters in the Auto Tune 
list.

12. Click the Auto Tune button. Notice that the status bar at the bottom of the NanoScope 
software window says “Cantilever Tuning” during automatic tuning. When tuning is 
complete, click Exit  in the Cantilever Tune dialog box. Proceed to Section 2.4.4, "Scanning 
and Scan Parameters".
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2.4.3 Preparing a MultiMode AFM for a Realtime Scan

Once you’ve created the workspace, prepare the system to scan. This includes selecting the
operation mode, mounting the probe, selecting the scanner, mounting the sample, aligning th
and adjusting the photodetector. If you have not yet learned these procedures, please refer t
Multimode Manual  and/or SPM Training Notebook.

1. Click Scan in the workspace to see the Scan View. In the Scan View parameters area, selec
the Other tab. Set the Microscope mode parameter to Tapping or Contact.

2. Change the mode switch on the base of the microscope. Set it to TMAFM  if you are using 
TappingMode. Set it to AFM & LFM  mode if you are using Contact mode.

3. Mount the probe into the cantilever holder.

4. Put the cantilever holder in the optical head. Secure the holder by tightening the screw
back of the optical head.

5. Choose a scanner (A, E, or J) by clicking on Tools > Select Scanner. Mount and plug the 
scanner into the base. Attach the corresponding springs to the microscope base. 

6. Mount sample onto scanner.

7. Place optical head on scanner, making sure there is enough clearance between the tip
sample.

8. Align laser.

9. Adjust the photodiode signal.

10. If you are using TappingMode, click the Tune icon. Check your parameters in the Auto Tune 
list.

11. Click the Auto Tune button in the Cantilever Tune dialog box. Notice that the status bar a
the bottom of the NanoScope software window says “Cantilever Tuning” during automa
tuning. When tuning is complete, click Exit  in the Cantilever Tune dialog box.

2.4.4 Scanning and Scan Parameters

Next, you set scan parameters and scan the sample.

1. In the Scan View, use the following initial parameter settings in the Scan tab. These values 
may already be set; they are handy starting values.

Scan size: 1µm

Aspect Ratio: 1.00

X offset: 0nm

Y offset: 0nm
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2. Most of these commonly-used parameters are also shown on the Main  tab. You can right-
click on the field in the Main  tab to open a dialog box that allows you to change which 
parameters are shown on the Main  tab.

3. To collect 4K points of data per line, set the following parameters in the Scan tab:

Note: You can use the mouse to adjust the value in many parameter fields. Click
the value and drag the mouse left to decrease the value or right to increas
value.

The Aspect ratio controls the X:Y ratio of the pixels in the displayed image. Since there is a 
8:1 ratio between 4096 samples/line and 512 lines using an Aspect ratio of 8 causes the pixels 
displayed in the image to be square. 

4. For TappingMode, use the following initial parameter settings in the Feedback tab:

5. For Contact mode, use the following initial parameter settings in the Feedback tab:

6. Click the Engage button in the Main  tab or click the Engage icon. Scan lines appear in the 
Scan View once the tip engages and scanning begins.

7. Click the Scope button. Check to see whether the trace and retrace lines are tracking ea
other well. They should have a similar shape, but they may not overlap each other 
horizontally or vertically. Adjust the Scan rate, Integral gain, Proportional gain, and/or 
Setpoint (that is, Amplitude setpoint for TappingMode and Deflection setpoint for Contact 
Mode) parameters. Once the trace and retrace are tracking well, your tip is scanning th
sample surface.

8. At this point, you may want to adjust the Scan size, X offset, Y offset, and Scan angle (Scan 
Tab) parameters to locate the scan over features of interest. If you increase the Scan size, 
remember that the Scan rate should be lowered.

Scan angle: 0.00 °

Scan rate: 2Hz

Samples/line: 4096

Lines: 512 (or 1024)

Aspect ratio: 8.00 (or 4.00 if Lines is 1024) and you want 
square pixels

SPM feedback: Amplitude

Integral gain: 0.2

Proportional gain: 0.3

Integral gain: 2.0

Proportional gain: 3.0

Deflection setpoint: 0V (vertical defection = -2V (before engage)
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Note: You can zoom in on the scan image by selecting the Zoom button below the 
image. Then, use your mouse to drag a box outline over the area you wan
zoom in on. Click Offset to offset the center position of your scan.

9. With a 4K image, it may be useful to zoom in on the scan without changing the scan si
Select the Data Zoom button above the image. Use your mouse to drag a box outline on
image (begin by clicking where you want the center of the box to be). When you releas
left button, you will be zoomed in (scan size of image display will change) but the scan
will remain scanning the original scan size. At this point you can choose to “pan” over t
other areas of the total scan. Select the Pan button and click and hold the left mouse button a
you move the mouse. The left arrow button above the image allows you to go back to t
original scan and the right arrow button allows you to go to more zoomed in scans (if y
have done multiple zooms). You may also choose to physically change the scan size o
offsets by using the Zoom or Offset.

2.4.5 Capturing an Image

Once you have adjusted the scan parameters, you can capture a scanned image. Perform th
once a scan you want to capture is in progress. 

1. You can capture a scan in any one of three ways:

• From the menu bar, select Realtime > Capture.

• From the menu bar, select Realtime > Capture Now.

• On the Main  Tab in the Scan View, click the Capture button. 

• Click the Capture icon in the toolbar.

The scan will continue. Notice that the status bar at the bottom of the NanoScope window (see 
Figure 2.4e) says “Capture: On.” When the current scan is complete, the image will be stored 
automatically in the Capture Directory with the file name indicated in the status bar. The file 
name and directory can be changed by selecting Realtime > Capture Filename from the 
menu bar (see Figure 2.4f).
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Figure 2.4e   Status Bar

Figure 2.4f   Change Filename

2. In the Image Browser area (see Figure 2.4g), check to see if you are looking at the Capture
Directory. If not, select the Capture Directory icon (or click the “...” button and select the 
Capture Directory, which is usually DI  > Capture). If you don’t see the Image Browser, 
choose View > Browse.

Capture Status
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Figure 2.4g   NanoScope Image View Window

3. Double-click the image you just captured. The image opens in the Image View window (see 
Figure 2.4g). Notice that the image filename and an image view are added to your 
workspace.

Image
Browse
Area

Image View
Rev. D Nanoscope Software 6.13 User Guide 27



Getting Started with NanoScope v6.13 Software
Quick Guide to a 4K Point Image

28

ght 

ar, 
4. If you need to change the DATA  SCALE , CONTRAST, OFFSET or COLOR TABLE , use 
Format > Color Scale on the menu bar or right-click on the data scale value in the top ri
corner of the Image View window, and change the appropriate values in the Color Scale 
popup window. The Color Table may also be changed by clicking and holding the color b
then dragging the mouse left or right.

Note: To rename image files, you can Save As, use Explorer to rename the file, or 
right-click on the image in the image browser and select Move.

Figure 2.4h   Color Scale

2.4.6 Analyzing an Image with the Section Analysis

After opening the captured image, you can analyze the image. In this example, the Flatten filter 
and Section analysis views are used.

1. Right-click on the name of the image in your workspace. Choose Add View > Flatten from 
the pop-up menu, select Analyze > Flatten from the menu bar, or click the Flatten icon.

The Flatten filter can be used to remove image artifacts due to vertical (Z) scanner drift, image 
bow, skips, and anything else that may have resulted in a vertical offset between scan lines. 
Refer to the Command Reference Manual, 004-122-000 for a detailed description of Flatten.

2. Set the input parameters for the filter. For example, you can choose the order of the 
polynomial to use to fit scan lines.

3. Click Execute.

4. To restore to the original data, click Reload. Then change the parameters and click Execute 
again.

5. Right-click on the name of the image in your workspace again. Choose Add View > Section 
from the pop-up menu, select Analyze > Section from the menu bar, or click the Section 
icon. Section analysis allows you to easily make depth, height, width, and angular 
measurements.
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6. Drag a line across the image. A vertical cross section along that line is shown in the up
graph area, shown in Figure 2.4i. The lower graph also shown in Figure 2.4i, shows the 
power spectrum (Fourier Transform) of the cross section.

7. In the upper grid, drag the two cursors around to make measurements. You can grab t
more measurement cursors from the outside of the grid. You will see the cursor change
a  to a , at which point you can grab the measurement cursors. The results area
bottom of the view shows various measurements at the marker position.

Note: Section can have three horizontal lines or 3 rotating lines or one rotating bo
can have three sets of grid markers on one image cursor or one set of grid
markers on each image cursor.

8. If you would like to make an Average Section, right-click on the image, select Rotating Box. 
After drawing the box, you can make it rotate by holding down the shift key while grabb
anywhere in the box.

Figure 2.4i   Section Analysis

2.4.7 ASCII Export

When transporting the results of using NanoScope software to another computing platform, 
most generic format is an ASCII text file. The File > Export  > ASCII  command builds such a file.
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1. Select a directory, then an image file within it, from the file browsing window at the righ
the NanoScope Version 6 main window. Right-click in the thumbnail image to open the 
menu shown in Figure 2.4j.

Figure 2.4j   The ASCII Export Command

2. Click Export  > ASCII  to open the Export  dialog box (see Figure 2.4k).
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Figure 2.4k   The File Export Dialog Box

3. Select the units in which to record the data in the new file by checking the appropriate b
You can also export image header, ramp, or time information by selecting those check 

4. Click Save As..., designate a directory path and filename, and click Save.

Figure 2.4l shows the start of an exported ASCII image file saved without a header.

Figure 2.4l   Sample ASCII Image File

2.5 Using Online Help

The NanoScope software now includes complete documentation in online Help, including: Th
Procedures and Interface references. 
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If the help is not open,

• Select View > Help or

• Use Help > Nanoscope Help to display and hide the Help window.

To manually select the Help file:

1. Select Tools > Options > Set Help File.

2. A browse dialog box appears to select the NanoScope 6 help file (see Figure 2.5a).

Figure 2.5a   Initialize Help Dialog Box

3. Select the NanoScope6.chm file.

2.5.1 Help Window

The Help window includes three tabs (see Figure 2.5b):

• Contents—Displays a list of topics and subtopics to search.

• Index—Allows searching by indexed items in alphabetical order.

• Search—Allows for searching the entire online help for a word or phrase.

Browse to select
the NanoScope file
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Figure 2.5b   Help Window

Contents

The Contents tab allows for scrolling between main topics and subtopics. Click on a topic to v
documentation in the right frame (see Figure 2.5b).

Index Tab

The Index tab allows to search the index of items, then select display to view the contents in 
right frame (see Figure 2.5c).

Note: Often, the indexed item displays the top level help page where the item is 
found. For viewing the exact location, select the indexed item, display the p
then select the contents tab to view the related topic of the indexed item.

Menu Tabs

Right Frame

List of Topics 

for Viewing 
Contents
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Figure 2.5c   Index Tab

Search Tab

The Search tab allows to search the entire help text, then view the content in the right frame (
Figure 2.5d).

Figure 2.5d   Search Tab

Right Frame
for Viewing
Contents

Search
Index
Field
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2.6 Technical Support at Veeco

Your satisfaction and productivity regarding Veeco products and documentation are absolute
essential. 

2.6.1 Submitting Bug Reports

The NanoScope software automatically generates a bug report if the system should abort fo
reason. This bug report form may help a Veeco programmer correctly analyze the problem th
caused the abort. 

If the system should abort, the next time the software is initiated a bug report form automatic
displays. You can also report a bug by selecting HELP > BUG REPORT... For submitting bug 
reports, complete the following:

1. Enter your name and a brief description of the functions in use when the crash occurre
Please describe the situation as accurately as possible.

Note: The form also includes crucial internal coding information for the develope

2. Select Ok to transmit the file.

Note: A file labeled BUG.TXT will be created in your SPM directory. If another bug.tx
file exists, the number on the file name is incremented or the information is
appended to the previous file. 

Note: If there is no SPM directory or bug.txt file, the software prompts to place th
file in another location. 

3. Once the file is created, attach the BUG.TXT file to an e-mail and send to bugs@di.com.

Note: You may not get a response to your bug submittal, but be assured that our
programmers will analyze the problem and fix it in a future release if neces

2.6.2 Contact Information

Mailing Address

Technical Documents, Technical Support or Bug Reports at Veeco
Veeco Instruments Inc.
112 Robin Hill Rd.
Santa Barbara, CA 93117

E-mail: help@veeco.com
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Voice Phone

(805) 967-1400, (800) 873-9750

Fax

(805) 967-7717

E-Mail (Documentation Feedback only)

TechPubsSBO@veeco.com

World Wide Web

http://www.veeco.com
Nanoscope Software 6.13 User Guide Rev. D
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The Realtime Views control the Realtime collection of data. Each part of the screen is an inte
part of the scanning process. For more information on controlling views and the workspace, 
reference Chapter 2.

For general procedures in setting the parameters and data definitions, refer to the following 
sections:

• Overview of Realtime Views: Section 3.1

• Views for Scanning Section 3.2

• Tips on Using Realtime Section 3.3

• Force Curves Section 3.4

• Auto Panel Section 3.4.5

Note: If you have never used an AFM before, please refer to your microscope ma
or contact Veeco for training.

3.1 Overview of Realtime Views

The Scan View includes all SPM parameters previously found in the Realtime control panels.
settings and parameters configure the microscope and NanoScope controller signals to optim
each scan. 

You can access Realtime views such as Scan-Single, Scan-Dual, Scan-Triple, Meter, Navigate, 
Video, and Point and Shoot by any of the following methods (see Figure 3.1a):

1. Right-click on Realtime in the workspace and select the desired view from the Add View 
menu.

2. Click on the desired view icon in the Realtime button bar.

3. Select a view from the Acquire menu.
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Figure 3.1a   Manual Scanning in Realtime

3.1.1 Typical Procedures to Begin to Scan

Set Scan parameters to affect piezo movement and data collection. The Scan functions control the 
type of scan to run, how large the scan is, its angle, scan rate, and number of samples per sc
Prior to scanning a sample, the user must have knowledge of the following:

• Basic SPM processes

• Microscope safety, handling and tip/probe handling procedures (see your system 
manual)

• Sample handling procedures
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3.2 Views for Scanning

The general interface views associated with configuring parameters for scanning include:

• Navigate View Section 3.2.1

• Meter View Section 3.2.2

• Point and Shoot View Section 3.2.3

• Cantilever Tune Section 3.2.4

• Scan View Interface Section 3.2.6

• Scope Trace Plot Section 3.2.7

• Main Tab Interface Section 3.2.8

• Scan Tab Interface Section 3.2.9

• Channels Tab Interface Section 3.2.10

• Feedback Controls Tab Interface Section 3.2.11

• Other Tab Interface Section 3.2.12

3.2.1 Navigate View

Use the Navigate commands to locate the tip, focus on the surface, enable the trackball and
the stage. Use the Navigate View (previously the Realtime > Stage menu commands) to position 
the tip, locate a surface position for referencing Z height and move the stage for scanning th
sample surface.

To access the Navigate View, click on the Navigate icon in the Realtime workspace. If the 
Navigate icon is not present, right-click Realtime in the workspace to view the functions menu. 
Select Add View > Navigate and the Navigate View appears in the client window.

Navigate Commands

The Navigate commands allow you to focus surface or locate the tip (see Figure 3.2a). To view the 
Navigate commands select Tools > Stage or the command icons for Focus Surface or Locate Tip. 
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Figure 3.2a   Navigate Menu Commands

Figure 3.2b   Navigate View
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Using the Navigate View

Access the Navigate View at any time when the stage movement or focus surface and locate t
settings are necessary.

Note: Some microscope options, such as Engage and Withdraw , are unavailable 
when the Navigate View is active. You must select another view, such as the
Scan View, to enable these options.

1. Access Locate Tip and Focus Surface in the Navigate View or select the appropriate icons

2. Select the Locate Tip button and focus on the tip using the trackball or arrow keys. Whe
finished, click the Ok button.

3. For Focus Surface, use the trackball or arrow keys to move the stage in X, Y or Z directi

Navigate View Parameters:

CAUTION: If Tip Focus is not accomplished before Focus Surface, there is a 
danger of crashing the tip during Engage.

XY Stage Motion Controls the horizontal, vertical and diagonal movement of 
the stage.

Speed Buttons allow for setting slow (S), medium (M ) and fast 
(F) stage speeds by entering a speed value to the right of 
the buttons or using the scroll bar then select the S, M or F 
button.

Z Motion Up and down arrow keys control the height movement of 
the tip toward or away from the stage.

Auto Focus Opens an Auto Focus dialog box to set the Z axis focus 
from vision settings.

Trackball Enables or disables the X, Y stage and Z cantilever move-
ment by using the trackball.

Camera Controls the magnification used to view the stage or tip. 
Range: High Mag, Low Mag.

Illumination Sets the light intensity in the optics.

Zoom Changes the optical field of view (i.e., without stage or tip 
movement).

Vision System Displays the surface (in focus surface mode) or tip (in 
locate tip mode) and tip on the surface (in Realtime scan-
ning mode).
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SPM Parameters

To access the SPM Parameter controls, select Tools > Engage Settings > General or right-click in 
Navigate View and select Edit SPM Parameters (see Figure 3.2c). Parameter Controls are:

• Sample Clearance

• SPM Safety

• SPM Engage Step

• Load/Unload Height

Figure 3.2c   Edit SPM Parameters Dialog Box

3.2.2 Meter View

Access the Meter View (select Acquire > Meter) to view the photodetector signal, RMS 
amplitude, horizontal and vertical deflection signals, and the signal sum. The meter can also
viewed in the docking RealTime status window.

Meter View Interface

• Photodetector Signal—Corresponds to the positioning of the laser on the photodiod
detector.

• Signal Sum—Sum of the voltage response from the laser in all 4 sections of the ph
detector.

• Vertical Deflection—Corresponds to the voltage for vertical displacement of the las
signal. Should be “0” for centering.

• Horizontal Deflection—Corresponds to the voltage for the horizontal displacement
the laser signal. Should be “0” for centering.
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• RMS Amplitude—Root mean square (RMS) signal measured at the detector 
(TappingMode only).

Figure 3.2d   Meter View and Docking RealTime Status Window
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3.2.3 Point and Shoot View

The Point and Shoot View allows you to select specific points on an image (see Figure 3.2e). Use 
Point and Shoot to capture an image and/or collect a force curve for every point you designat

When you click a point on an image, a crosshair (+) marks the location. You can designate 
individual points, or use the tools in the Point and Shoot View to assign multiple points 
simultaneously. 

Figure 3.2e   Point and Shoot View

Controls and Parameters

Image/Scan Allows you to switch to Image/Scan mode. Use Image/
Scan mode to adjust scan parameters in any scan view.

Ramp/Force Curve Allows you to switch to Ramp/Force Curve mode. Use 
Ramp/Force Curve mode to adjust the ramp settings. You 
can select points on an image, ramp each point, and create 
a force curve for each point.

Image Channel Select the channel to use for the image.

Ramp Channel Select the channel to use for the ramp display.

Multiple Shoot Number of force curves collected at each point, 100 max.
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Capture Image and 
Ramp

Click this button to capture an image and save it in the 
Capture Directory, and to then capture a force curve at 
each designated point.

Capture Image Click this button to capture an image and save it in the 
Capture Directory. After the capture the software switches 
to Ramp/Force Curve mode.

Ramp Click this button to ramp a variable determined from the 
force curve menu at each point.

Capture Click this button to ramp each point, capture the ramp/
force curve, and save it in the Capture Directory.

Point Parameters Image Cursor Mode Settings:

Mark Only —Select points of interest on the image.

M/Ramp—Select points of interest. Software will auto-
matically ramp each point.

M/R/Capture—Select points of interest. Software will 
automatically ramp each point and capture a ramp/force 
curve.

Line Parameters Draw a line to select specific points on an image.

Point Number—Number of points in the line.

Spacing—The distance in nm between each point. All 
points are equidistant.

Clear Path—This button clears the current line and asso-
ciated points.

Convert to Points—Places a + in the location of each 
point in the line. The line disappears.

Box Parameters Draw a box in the area you want to place a group of points. 
You can use the parameters below to create a grid of 
points.

Row Number—Designates the number of rows of points 
in the grid.

Column Number—Designates the number of columns of 
points in the grid.

Row Space (nm)—Designates the distance in nm between 
each row of the box.

Col Space (nm)—Designates the distance in nm between 
each column of the box.

Clear Path—This button clears the current box and asso-
ciated points.

Convert to Points—Places a + in the location of each 
point in the grid. The box disappears.

Clear All Marks Removes all user-defined marks from the Point and Shoot 
image.

Save Marked List... Save the marks on the image as Path Files (*.psm).
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Two options are available for moving, in XY, from one point to another:

1. XY MOVE  ON SURFACE: OFF - Move with tip at home (lift) height.

2. XY MOVE  ON SURFACE: ENABLED - Move on surface with Z feedback on See Figure 3.2f.

Figure 3.2f   Ramp Parameters > Auto > XY move on surface

3.2.4 Cantilever Tune

The Cantilever Tune command allows determination of the cantilever resonant frequency and
setting of the operating point for TappingMode feedback (see Figure 3.2g). In addition, it is 
possible to determine the spring constant of a Contact Mode cantilever quickly and easily. 
Cantilever Tune sweeps the cantilever drive frequency over a selectable range, then displays a p
of the cantilever amplitude versus drive frequency on the Display Monitor. This command is 
enabled only when the Microscope mode parameter on the Other Controls panel is set to 
Tapping. On Small Sample MultiMode SPMs, verify that the switch located on the base is tog
to TM AFM  before selecting the Cantilever Tune command. 

Note: The sweep channel is determined by the data selection in the Channel 1, 
Channel 2, or Channel 3 control panels.

Figure 3.2g shows how the maximum amplitude is attained in air at the cantilever natural 
resonance. Figure 3.2h shows the amplitude is reduced when it is in contact with the sample 
surface.

Load Marked List... Opens and loads a previously saved Path File (*.psm) 
which contains marks on a Point and Shoot image. 
Note: If there are points on the image prior to selecting this 
option, when this button is selected the saved marks will 
appear in addition to the previous marks.
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Figure 3.2g   Tapping Cantilever in Mid-air

Figure 3.2h   Tapping Cantilever on Sample Surface

In TappingMode, the optical lever technique reflects a laser beam off the back of the oscillati
cantilever, thence to a segmented photodiode. The differential signal between the top and bo
photodiode segments provides a sensitive measure of cantilever deflection. As the sample is
scanned, analog circuitry determines the RMS value of the rapidly changing cantilever deflec
signal. The RMS value of the cantilever deflection signal corresponds to the amplitude of the
cantilever oscillation. Changes in amplitude of the cantilever oscillation is controlled by the 
feedback system to track the sample surface.

Access the Cantilever Tune dialog box by selecting the Tune icon or by selecting 
Tune... from the Realtime menu.

Laser

Cantilever
Resonant
Deflection 

Tapping Piezo

Photodiode
Detector

Photodiode
Detector

Laser

Cantilever
Resonant
Deflection 

Tapping Piezo
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Figure 3.2i   Cantilever Tune Dialog Box

Select Cantilever Tune Dialog Box Definitions:

Mode box Toggles the Auto Tune signal from the main to interleave sig-
nals.

Settings:

Main— Displays the set of parameters applied to the main scan 
(see Section 3.2.8).

Interleave—Displays a duplicate set of parameters applied 
only to the interleaved portions of the scan.

Auto Tune Button Executes the automatic tuning procedure: the cantilever is 
excited through a range of frequencies beginning at the Start 
frequency and ending at the End frequency.

Auto Tune
Button

Mode Box

Auto Tune
Parameters

More Button
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Auto Tune Parameters:

Start Frequency Starting point of the Auto Tune frequency sweep.

End Frequency Ending point of the Auto Tune frequency sweep.

Target Amplitude Targeted output signal amplitude at the photodiode detector. This value 
should not be confused with Drive amplitude, which is the amplitude applied 
directly to the cantilever itself (see Drive amplitude).

Range and Settings: 0.00 to 8.00 V

Note: Dimension Series SPMs, nominal = 2.00V
          Small Sample MultiMode SPMs, nominal = 3.00V

Peak Offset Percentage of cantilever’s free-air resonant frequency to be automatically off-
set. Peak offset is used to compensate for changes in resonance before 
engagement due to the tip’s interaction with the surface after engagement.

Range and Settings: 0 to 50%; typical value = 1 to 2%

Minimum Q Q is the value defined by the amount of oscillation it takes for a wave to drop 
to 1/e (e = 2.718) of its amplitude value (i.e. a wave with an amplitude of ten 
would have a Q of 10/e, or 3.6788). Minimum Q establishes a minimum 
“width of peak” value allowed by the AutoTune function. Peaks not meeting 
the Minimum Q may be ignored by setting the Smash Q factor.

Smash Width Factor The width of the area beneath the wave smashed (set to zero) when a peak not 
meeting the Minimum Q requirement is found. 
Note: This parameter does not appear if Minimum Q is 0.
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3.2.5 Electric Tune

Theory

When evaluating Surface Potential, you can now tune the cantilever electrically. Traditional 
cantilever tune oscillates the cantilever via tapping piezo material (see Figure 3.2j). Electric Tune 
sweeps the frequency of the electric field surrounding the cantilever. The force of the electric
moves the cantilever. The cantilever amplitude is then plotted in the Generic Sweep dialog box.

Figure 3.2j   Cantilever Tune Method Comparison

Traditional Cantilever Tune

Electric Field

Electric Field

Piezo Material Oscillates the Cantilever

Electric Tune 

Change the Electric Field Frequency
to Oscillate e the Cantilever
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1. While evaluating Surface Potential in Realtime mode, select RealTime > Generic Sweep. 
The Generic Sweep dialog box will display.

Figure 3.2k   Typical Generic Sweep

2. In the Generic Sweep dialog box, set the Sweep parameters Input igain  and Input pgain to 
0. This disables the Surface Potential feedback loop, which works to keep the cantileve
amplitude at zero.

3. Select Interleave as the Mode (see Figure 3.2k).

4. You can adjust several parameters to acquire interesting data:

• Try changing the Data Scale, Drive Phase and Drive Amplitude  (see Figure 3.2l).

• Try changing the channel. For example, the Data Type can be changed to Potential 
Input .

• Try sweeping another channel. For example, set the Graph parameter Sweep Output to 
Bias (see Figure 3.2l).

Interleave Mode
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Figure 3.2l   Electric Tune Generic Sweep while adjusting the Drive Amplitude and Drive Phase

Note: Remember to re-enable the Input  gains before collecting further Surface 
Potential data.

3.2.6 Scan View Interface

The Scan View display includes an image viewer, color bar, scope viewer, vision control viewe
(for systems configured with vision controls), and numerous parameters to configure Realtim
collection. Most SPM operators use only a few of these parameters to obtain images. The 
parameters within each tab are also microscope-specific or level-access dependent and may
greyed out or hidden, depending on microscope configuration.

Scan View Interface:

Image Window During scanning, the Realtime image of the sample appears along with a c
sor. The cursor moves along the image vertically to show the engaged tip p
tion on the surface. The Measure button allows you to make line 
measurements. The Data Zoom button allows you to “zoom in” to a smaller 
view, but doesn’t change the scan size. The Pan button allows you to pan over 
to other areas of the total scan if you are zoomed in.
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Figure 3.2m   Scan View and Main Controls

User-Defined Parameters in the Scan View

Clicking on a parameter and then dragging the mouse back and forth increases or decrease
parameter value much like an old analog slider. The significance, range of acceptable values
specific information about control panel parameters are discussed in this section.

Parameters listed in the Scan tabs depend on the microscope selected and the Show All Items 
function (right-click on tab interface > Show All). Parameters necessary for one style of microsco
are not applicable to another. For example, the Drive frequency and Drive Amplitude  parameters 
are enabled on the Feedback tab only when the mode is set to TappingMode.

Some users find operating an SPM less confusing if the number of parameters is limited to o
most essential ones. For this reason, The Main  tab in the Scan View contains user specified 
parameters.

Color Bar Sets the color table for viewing height data in the image window. Left-click 
on the color bar and drag the mouse left or right.

Image Parameters Configure options below the image window to select the channel and imag
display values, (e.g. Data type, Line direction, Data scale, and so on).

Vision Window The Vision window displays the Optics or Scope data. Select the Video or 
Scope or Line Plot button.
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3.2.7 Scope Trace Plot

Select the Scope button in Scan View (see Figure 3.2m) for a scope to display a plot versus the 
probe position in an oscilloscope-type format on the image display (see Figure 3.2n).

Figure 3.2n   Scope Grid

Scope Trace Interface

By right-clicking the Scope grid, you will get a menu of different options (see Figure 3.2o).
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Figure 3.2o   Scope Grid Parameters

 These menu options allow you to make the following changes:

Color Allows operator to change color of:

• Curve (data)

• Text

• Background

• Grid

• Minor Grid

• Markers

Filter Typically used for a Profiler Scan.

• Type—Allows the user to plot the mean, maximum or 
minimum y-value per x-value.

• Points—Allows user to plot multiple vertical axis (y-)values 
at each horizontal axis (x-)value. Select 4K, 8K, 16K or 32K 
Points to limit the display to 4, 8, 16 or 32 times 1024 points.

Minor Grid Places a minor grid in the background of the Vision Window.

Scale Allows user to auto scale, set a curve mean, or set their own data range.

Y Translate Offsets the curve by placement of vertical cursor on the grid. Grab vertical 
cursor in the black space above the grid and pull down onto grid.

Line Style For each curve, operator can choose, connect, fill down, or point.
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User Preferences Restore—Reverts to initial software settings

Save—Saves all changes operator has made during this session. This 
becomes the new default settings.

Copy Clipboard Copies the grid image to the Microsoft Clipboard.

Print Prints out the current screen view to a physical printer.

Export Exports data in bitmap, JPEG or XZ data format.

Active Curve Determines which curve you are analyzing.
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3.2.8 Main Tab Interface

 Figure 3.2p shows an example of parameter controls and settings for scanning in TappingMo

Figure 3.2p   Main Controls Panel

Engage Button The Engage command brings the tip into contact with the sample surface an
starts the Realtime imaging process.

Withdraw Button The Withdraw  command stops the scanning process and withdraws the tip 
from the surface.

Frame Down Button The Down command restarts the Realtime scan at the top of the frame. This

allows you to go directly to the start of the frame and not have to wait for th
previous frame to end.

Frame Up Button The Up command restarts the Realtime scan at the bottom of the frame. It is

an easy way to begin a view an entire Realtime frame from the bottom. By
clicking on this icon, the Realtime scan restarts and moves up at the bottom
the frame. This allows you to go directly to the start of the frame and not ha
to wait for the previous frame to end.

Capture Button The Capture command stores the image data of the current scan. During the
image scanning process, the cursor moves up and down a square image fra
When the cursor moves up or down one complete frame the Capture is com-
plete and an image file is saved.

Capture Cancel Button The Capture Cancel command stops the capture process.
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Procedures to Set the Main Tab

The parameters in the Main Control panel (see Figure 3.2q) are unique to your specific needs. 
Configure specific parameters as follows:

1. Right-click in the Main Control  panel.

2. In the Parameter list, verify each Scan View tab name.

3. Expand the desired tab name by clicking on the plus (+) sign next to each name (i.e., S
Feedback, Interleave, etc.) to view a list of parameters.

4. Highlight the desired parameters for viewing on the Main Controls tab.

Note: Only eight parameters may be selected. Therefore, take note of the most u
parameters to view in the Main  Controls tab.

5. With the parameter selected, click the double arrows (<<) to position the selected para

6. Repeat Step 2 - Step 5 for displaying eight main controls parameters for viewing during th
scanning process.

Select Ok to accept the changes or Cancel to revert to the previous view.

Figure 3.2q   Select Scan View Controls
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3.2.9 Scan Tab Interface

The Scan tab (see Figure 3.2r) includes parameters influencing piezo movement and data 
acquisition, as well as the ability to execute non-square scans. This Tab panel is probably the most
frequently used panel, as it controls what type of scan to run, how large the scan is, its angle
rate, and number of samples per scan line.

Figure 3.2r   Scan Tab Parameters

Scan Tab Parameters

Scan size Determines the size of the scan by controlling the voltage applied to the 
X and Y piezos.

Range or Settings:

• 0 to 440V

• 0 to XXµm  (scanner-dependent)

The units of this parameter are volts if the Units parameter (Other Con-
trols panel) is set to Volts. The units are linear distance (nm or µm) if 
the Units parameter is set to Metric .

See also, Optimizing the Scan Size Parameter on page 85.

Aspect ratio Controls the width-to-height size ratio of scans. Set Aspect ratio to 1.00 
for square scans. An Aspect ratio of 2.00 yields scanned images having 
width equal to twice the height. 

Range or Settings: (depends upon the number of scan lines) 1 to 256.
Rev. D Nanoscope Software 6.13 User Guide 59



Realtime Views
Views for Scanning

60
Figure 3.2s   Aspect Ratio Example

Figure 3.2t   Scan Angle Rotated Example.

X offset, Y offset Controls the center position of the scan in the X and Y directions, 
respectively.

Range or Settings: ±220V; ± XXµm (dependent on Scan size and 
scanner).

See also, Optimizing the X Offset, Y Offset Parameter on page 85.

Scan angle Controls the angle of the X (fast) scan relative to the sample.

Range or Settings: 0 to 359° (Any angular value can be entered with 
the keyboard)

Changing this parameter can dramatically affect the quality of 
images due to tip effects (tip side wall angle).

Setting this parameter to a setting besides 0 or 90° may reduce the 
maximum allowable Scan size 10-20 percent due to corner con-
straints (see Figure 3.2t).

Scan rate The Scan rate sets the number of fast scan lines performed per sec-
ond. When the Scan rates are low, it can take a fairly long time to 
scan an entire frame. For example, With the Scan rate set to 0.5Hz 
and the Number of samples set to 512, it can take over 17 minutes 
to capture a single image.

Range or Settings: 0.1-237Hz, depending on the number of 
Samples/line.

See also, Optimizing the Scan Size and Scan Rate Parameters on page 85.

1.00

4.00

8.00

16.00
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Table 3.2a   File Size/Samples per line

Note: Samples/line should be kept at 512 or higher for high resolution scans. To 
increase the frame rate (rate at which complete images are generated), th
Lines parameter should be reduced. When the Lines parameter is reduced, file 
sizes in Table 3.2a are reduced accordingly.

Note: Disabling the Slow scan axis and viewing the Scope Mode display is a 
convenient way of setting the Feedback Gain parameters. 

Lines Selects the number of lines to scan in a frame. The Lines parameter 
reduces resolution along the Y axis. It also speeds imaging (or frame 
rate) and reduces the size of the resulting image file. 

Range or Settings: 2 to 1024. The maximum number of lines may be 
limited by the value for Samples/line.

Tip velocity Velocity of the tip (in µm/s) as it scans over the surface.

When Tip Velocity is changed, the Scan Rate adjusts automatically.

Samples/line Selects the number of sample data points per scan line.

When this parameter is changes, the number of scan lines per image 
(Lines) are automatically adjusted to maintain the same ratio 
between the samples/line and lines per image.

Range or Settings: 128 to 16384. This setting influences the memory 
size of captured files and image resolution (see Table 3.2a).

Samples/line value
File size (for square 
scans, including 8K 

header)

128 40Kb

256 136Kb

512 520Kb

Slow scan axis Allows the slow scan to be disabled, causing the fast scan to be 
repeated continuously at the same position. This means that the image 
displays the same line continuously. Images may be presented either as 
“true” X-Y renderings of the sample surface (Enabled), or as 
“stretched” single-line scans of length equal to the Scan size (Dis-
abled).

Range or Settings:

• Enabled—Sample is scanned in the slow scan 
direction. (This is the normal setting of this parameter.)

• Disabled—No scanning of the sample in the slow 
direction is performed. The fast scan is repeated at the 
same position.
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The advantage of using the Slow Scan Axis > Disabled parameter is to emphasize one area (line) 
adjust SPM parameters. For example, an area of the image appears fuzzy (believing SPM 
parameters are not optimized for the sample). Disable the Slow Scan Axis, view the image in 
Scope mode, and reconfigure scan parameters to optimize the scan. 

Note: Setting the Slow scan axis parameter to Disable stops the slow scanning of the
piezo, but does not stop the movement of the Realtime display in Y. Lines 
replicated in the Y direction.

3.2.10 Channels Tab Interface

The Channels tab (see Figure 3.2u) consists of parameters for three channels. Each channel 
represents a unique scanning image. Up to three data Channels may be opened by selecting each
channel and choosing a data type to view simultaneously, opening up Realtime 3 times. Cha
are numbered 1, 2 and 3 and feature their own control panels. When a Data type is selected on
Channel, its image appears on the Display Monitor. It is possible to have up to three separat
images from each scan. For example, a TappingMode scan might simultaneously present a Height 
image on Channel 1, a Deflection image on Channel 2, and an Amplitude  image on Channel 3. 

Parameters shown on each Channel control panel vary slightly, depending upon the type of 
microscope selected and its operating mode. 

Figure 3.2u   Channels Tab
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Channel Tab Parameters

Data Type Range or Settings 

Data Type Settings vary, depending upon the microscope selected and operating mode 
as shown in the field descriptions below. The Data type parameter may 
receive: no data (Off ); sample-height data (Height); cantilever oscillation 
amplitude data for TappingMode (Amplitude ); cantilever deflection data 
(Deflection); STM current data (Current ); phase data (Phase).

     See also, Optimizing the Data Type Parameters on page 86.

Amplitude (TappingMode 
and Force Mode only)

The RMS of the cantilever amplitude signal is displayed and captured.

Current (STM only) Data displayed and captured is the tunneling current generated by the pr
plifier. (When set to Current , the units of the data are nA.)

TM Deflection Cantilever deflection signal data is displayed and captured. (When set toTM  
Deflection, the units of the data are in distance or volts.)

Height The Z piezo voltage set by the feedback calculation in the Digital Signal 
cessor (DSP) is displayed. (The displayed data comes from the voltage o
to the Z piezo.) Units are distance (e.g., nm, µm, etc.). Standard imaging of 
topography.

Off Channel is turned off.

Phase (MFM, EFM) Phase data from oscillating TappingMode tips, generally used with Magn
Force Microscopy (MFM) and Electrical Force Microscopy (EFM), is dis-
played and captured. This setting appears when the microscope is config
with an Extender™ Electronics Module.

Potential (EFM) Surface potential data is displayed. (For detailed information on Surface 
Potential or EFM features, see Support Note 231, Electric Force Microscopy 
on the MultiMode Systems.)

Thermal Temperature data from thermal tips is displayed and captured. 

Deflection Cantilever deflection signal data is displayed

Friction Torsional deflection signal data is displayed
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Data scale The Data Scale controls the Z scale corresponding to the full height of th
play and color bar.

Range or Settings:

• 0.0067 to 440V (Data type set to height, Units are set to 
volts).

• XX  to XXX µm  (Scanner dependent; where Data type is set to 
height, Units set to metric).

• XX  to XXX µm  (Sensitivity dependent; where the Data type 
is set to deflection or amplitude; Units are set to metric).

• 0.00003815 to 2.5V or 20V (Data type set to amplitude; Units 
set to volts or deflection)

• 0.0031 to 200nA (Data type set to current; Units are set to 
metric).

• 0.0003052V to 20V (Data type set to current; Units are set to 
volts).

See also, Optimizing the Data Scale Parameters on page 86.

Data center Offsets centerline on the color scale by the amount entered.

The Data Center offset does not become a permanent part of the data.

Range or Settings: 

• ± 220V

• ± TappingMode

Line direction Selects the direction of the fast scan data collection that is displayed in t
image.

The feedback calculation is always performed regardless of the scan dire
This parameter simply selects whether the data is collected on the trace 
retrace. This parameter selects the relative motion of the tip to the samp

Range or Settings:

• Trace—Data is collected when the relative motion of the tip
left to right as viewed from the front of the microscope.

• Retrace—Data is collected when the relative tip motion is 
right to left as viewed from the front of the microscope.

Scan line The scan line controls whether data from the Main  or Interleave scan line is 
displayed and captured. 

Range or Settings: Main  or Interleave

This parameter is not selectable when the Interleave mode parameter is set to Disable. The system is locked 
on the Main  scan lines whenever the interleaved mode is turned off.
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3.2.11 Feedback Controls Tab Interface

The Feedback Controls parameters allow for monitoring the signals between the NanoScope 
Controller  and the cantilever. These signals adjust the setpoint, oscillation frequency, drive vo
Z response for surface tracking, and output voltages. The purpose of the Feedback Controls is to 
maintain a constant setpoint (deflection, amplitude, or current) in the Feedback Loop for tip/
sample control and tracking optimization.

Figure 3.2v   Feedback Controls Tab in TappingMode

Realtime Planefit Applies a software leveling plane to each Realtime image, removing up to first-
order tilt. Three types of planefit are available to each Realtime image.

Range or Settings:

• None—Only raw, unprocessed data is displayed.

• Offset—Takes the Z-axis average of each scan line, then subtrac
it from every data point in that scan line.

• Line—Takes the slope and Z-axis average of each scan line and
subtracts it from each data point in that scan line. This is the 
default mode of operation, and should be used unless there is a
specific reason to do otherwise.

 Offline Planefit Applies a software “leveling plane” to each captured image for removing up to
first-order tilt. Three types of planefit are available to each Offline image.

Range or Settings:

• None—Only raw, unprocessed data is displayed.

• Offset—Captured images have a DC 21 offset removed, but they
are not fitted to a plane.

• Full—A best-fit plane which is derived from the data file 
subtracted from the captured image.

See also, Optimizing the Offline Planefit Parameter on page 86.
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Feedback Control Parameters

Z Modulation (Fluid TappingMode 
only)

Allows the user to add the drive oscillation signal to the Z piezo
voltage. This parameter is used to set up fluid cell oscillation in
any Dimension system for Fluid TappingMode.

Range or Settings:

• Enabled—Enables Z modulation. Drive 
oscillation signal (Drive Frequency) is added to Z
piezo voltage. When enabled, the Z limit must 
be set ≤ 420V.

• 0—Disables the Z modulation (i.e., no additional 
signal is added to Z piezo voltage).

The desired Drive amplitude and Drive frequency voltages 
(Realtime > View > Sweep > Cantilever Tune) need to be set 
for Fluid TappingMode operation.

SPM feedback Selects the signal to be used for tip feedback according to the 
selected Microscope mode parameter (Other Controls panel). 
For Contact AFM, the choice defaults to Deflection; however, for 
TappingMode, you may select either the Deflection or the 
Amplitude . STM offers three choices of feedback: Linear, Log 
and Boost.

Range or Settings:

• TappingMode—Amplitude, TM Deflection- 
Phase (Forcemod only)

• Contact Mode—Deflection only

• STM—Linear , Log, Boost

   Linear—The linear difference between the instantaneous tun
neling current and the Setpoint current is used in the feedback 
calculation.

   Log—The difference between the log of the instantaneous tun
neling current and the log of the Setpoint current is used in the 
feedback calculation.

   Boost—Optimizes the feedback performance for high Scan 
rates over rough surfaces. This is not intended for atomic images

     See also, Optimizing the STM Feedback Parameters on page 87.

Input Feedback Controls Frequency Modulation (MFM or EFM) and Surface 
Potential.

Integral Gain Controls the amount of integrated error signal used in the feed
back calculation.

Range or Settings: 0 to 1024
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Table 3.2b    Typical Integral Gain Ranges:

     See also, Optimizing the Integral and Proportional Gain on page 87.

Gain settings vary, depending upon the scanner used, the sample and scanner sensitivity. See Table 3.2b for 
approximate, nominal values (assumes a Scan rate of ≈ 2.5Hz).

Scanner Contact AFM and 
Forcemod TappingMode STM

Aa

a. For atomic-scale images, scan rate must be increased to approximately 
60 Hz.

1.0 - 8.0 0.2 - 1.0 0.3 - 5.0

Proportional Gain Controls the amount of the proportional error signal used in the
feedback calculation. The Proportional gain term in the feed-
back calculation has equal gain at all frequencies; therefore, it 
has a dominating effect over the Integral gain for high frequen-
cies (scan rates).

Range or Settings: 0 to 1024

(Typical settings for the Proportional gain parameter are 35-
100% more than Integral gain values).

LookAhead Gain Adjusts Z-axis tracking of the sample surface by “remembering
previous scan line data, then anticipating adjacent surface fea-
tures on the current scan line. Look ahead gain is a valuable 
assist to the Integral gain parameter when scanning regular, ste
features such as gratings and integrated circuits (e.g., by decre
ing tip overshooting, etc.).

Range or Settings: 0 to 1

    See also, Optimizing the Look Ahead Gain Parameter on page 87.

Setpoint The meaning of this parameter depends on the operating mode
the microscope as follows:

Amplitude Setpoint (TappingMode)—defines the amplitude of 
the cantilever oscillation signal to be maintained by the feedbac
loop. (Range: 0.00 to 10.00V)

Deflection Setpoint (Contact Mode)—Controls the deflection-
signal level used as the constant desired voltage in the feedba
loop. (Range: 10.00 to 10.00 V)

Current Setpoint (STM)—Controls the constant current main-
tained by the feedback loop. (Range: 0.0 to 100.0nA)
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Drive frequency (TappingMode and 
Force Mode only)

Selects the oscillation frequency applied to the piezoelectric 
crystal that vibrates the cantilever.

Range or Settings: 0.00 to 250MHz

The Center frequency is adjusted with the Cantilever Tune 
command to find the resonance frequency of the cantilever. Th
maximum cantilever oscillation amplitude occurs at its resonan
frequency. The software sets the Drive frequency equal to the 
current Center frequency value when the Ok button in the Can-
tilever Tune control panel is pressed.

Drive Phase (TappingMode and Force 
Mode only)

Selects the phase of the drive voltage applied to the piezoelect
crystal that vibrates the cantilever.

Drive amplitude (TappingMode and 
Force Mode only)

Selects the amplitude of the drive voltage applied to the piezo-
electric crystal that vibrates the cantilever.

Range or Settings: 0.00 to 20.00V

The Drive amplitude is also adjusted with the Cantilever Tune 
command. Increasing the Drive amplitude increases the cantile-
ver-oscillation amplitude. The cantilever-oscillation amplitude is
increased to an appropriate level with the Cantilever Tune com-
mand. In AutoTune, the Drive Amplitude  automatically adjusts 
to get a cantilever oscillation (rms amplitude) equivalent to the 
user’s Target amplitude.

Bias Controls the sign and magnitude of the bias voltage applied to 
the sample.

Range or Settings: -10.00 to 10.00V

When used with STM, typical settings for the Bias voltage 
parameter are 20 to 100mV for conductive samples and up to 
several volts with poorly conducting samples. Positive settings o
the Bias voltage item correspond to negative current (electrons)
tunneling from the tip into the sample on heads with the Bias 
applied to the Sample or Tip .

Analog 1, 3, 4 This voltage has no effect on the operation of the standard mic
scope, but is useful in custom applications.

Range or Settings: -10.00 to 10.00V. These settings are only 
displayed with either NSIV or NSIIIA with Quadrex 
extender.

Aux Lockin Directs an external input signal through the auxiliary lock-in 
amplifier.

Drive Phase The phase of the AC bias signal applied to stimulate piezore-
sponse.

Lockin BW The bandwidth of the effective bandpass filter centered on the 
TTL level reference frequency (i.e., the cantilever drive fre-
quency in the NSIV Controller) used by the main lock-in ampli-
fier.
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InterSave Parameters Range or Settings

Several parameters (e.g. Z modulation, SPM Feedback, etc.) are highlighted by dark gray or
background. Dark grey indicates that the parameters are coupled with the equivalent values 
Feedback controls. By selecting (left-click) the Interleave parameters, the grey field turns gre
indicating that the Feedback and Interleave parameters are decoupled and the value in thos
parameters will be used as feedback during the interleave scan line.

Interleave Mode

• Interleave—Adds a second, interleaved set of lines to the scan, which can be acce
from the Channel panel and captured as data. Invoking Interleave reduces the slow
speed by one-half and doubles the capture time.

• Lift— A variant of Interleave, the Lift option uses the first set of scan lines to detec
surface, then lifts the probe above the sample surface on the interleaved set of sca
according to the Lift start height and Lift scan height parameter settings. During th
Interleaved scan, the tip mimics the surface topography from the previous surface 
line (see Figure 3.2w). 

Figure 3.2w   Interleave Lift Mode

• Linear—Lifts the tip to a predetermined height and runs the interleave scan at that
height. 

• Disabled—Turns off the interleave scanning.

• Retrace Lift—Lifts after the trace scan in the retrace direction. This parameter is 
optimized with the Rounding parameter (Microscope > Calibrate > Scanner > 
Rounding). The suggested rounding setting is 0.2.
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Figure 3.2x   Retrace Lift Mode

Figure 3.2y   Lift Scan Height Illustrated

Lift scan height Specifies the tip’s height above the sample surface during interleaved scans. 
This parameter is in effect ONLY when the Interleave mode parameter is set 
to Lift, Linear, and Retrace Lift (see Figure 3.2y).

Range or Settings: XXµm (Scanner dependent)

The maximum meaningful value of the parameter depends on the Z voltages 
applied in the Main  scan line and the maximum voltage that the system can 
output. The maximum voltage that can be applied to the piezo is ±220V. It 
will be lower if the Z voltage is restricted by the Z limit  parameter.

Lift start height Specifies the height that the tip is to be lifted above the sample surface at the 
start of each interleaved scan. Generally, this parameter serves to lift the tip 
clear of any contamination layers present on the sample before assuming its 
Lift scan height during interleaved scans. This parameter is in effect ONLY 
when the Interleaved mode parameter is set to Lift and Retrace Lift. This 
parameter defines an offset from the Z voltage, or height, applied to the piezo 
on the Main  scan line.

Range or Settings: XXµm (Scanner dependent)
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Figure 3.2z   Lift Start Height Illustrated

Tips for Using the Lift Start Height Parameter

• This value can be left at zero for TappingMode and STM. It is generally only used 
Contact AFM to break the tip free of the adhesive force produced by the water laye
before settling to the final tip height.

• The maximum meaningful value of the parameter depends on the Z voltages appli
the Main  scan line and the maximum voltage that the system can output. The maxi
voltage that can be applied to the piezo is ±220V. It will be lower if the Z voltage is 
restricted by the Z limit  parameter.

The tip will go through this height at the start of every lifted scan line, then proceeds to the lift
height for the rest of the scan line. 
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3.2.12 Other Tab Interface

The Other Controls parameters set the type of microscopy, Z tracking limits, units to use in 
measuring and other parameters specific the to microscope mode (i.e., the parameters that a
the Other Controls panel will vary from one microscope to another). In the Workspace menu, 
select R001 Time. In the Realtime Scan window, select the Other tab.

Figure 3.2aa   Other Tab

Parameters in the Other Controls Tab:

Microscope mode Selects the type of microscopy to be employed. Switching this parameter 
enables/disables other parameters. Also, on MultiMode  SPMs, any change 
to the Microscope mode must be accompanied by use of the mode selector 
switch on the microscope’s base.

Range or Settings:

Contact, Tapping or STM

Z limit Permits attenuation of maximum allowable Z voltage and vertical scan range 
for achieving higher resolution (smaller quantization) in the Z direction.

Range or Settings:

11 to 440V (with Units set to Volts) for the XY Closed loop head
11 to 330V (with Units set to Volts) for the XYZ Closed loop head

FM igain Integral gain for Frequency modulation. Controls the feedback loop that uses 
phase electronics.

FM pgain Proportional gain for Frequency modulation. Controls the feedback loop that 
uses phase electronics.
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Deflection Limit Use this parameter for attenuating the input voltage signal (appears only 
when performing Contact AFM). 

Range or Settings:

•  2.500V to 20.0V for regular imaging

•  20.00V in Force Mode only

Amplitude Limit Use this parameter for attenuating the input voltage signal (appears only for 
TappingMode or STM).

Range or Settings:

• 2.500V for regular imaging

• 20.00V in Force Mode only

Illumination Controls the fiber optic illumination of the sample in Dimension series 
microscopes.

Range or Settings: 0 to 100, recommended range is 20 to 50

Units Selects whether the units of certain scan parameters are in Volts or in units of 
Metric distance (nm, etc.). Parameters affected include Scan size, X Offset, 
Lift start height and Lift scan height, Y Offset, Data Scale, Z Limit, Z Scan 
Start, Ramp Size, Column Step and Row Step.

Range or Settings:

• Volts—Parameters are in Volts.

• Metric— Parameters are in units of distance (nm, µm, etc.) 
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Engage Setpoint (Tap-
pingMode only)

Allows the user to correct for loss of tracking on engage due to sample dif-
ferences. The automatic Engage procedure establishes the setpoint voltage at 
the smallest possible value that detects the sample surface, resulting in a 
value that protects both the sample surface and the cantilever tip. However, 
this value may not be sufficient for optimal surface tracking on all samples. 
The setpoint voltage determined by the automatic Engage procedure will be 
multiplied by the Engage Setpoint value, increasing or decreasing tapping 
force.

Range or Settings: 

0.5 through 2.0. A value of 1.0 results in no change to the tapping force. Val-
ues less than 1.0 increase the tapping force and values greater than 1.0 
decrease the tapping force. A value of 0.9 is nominal for most samples.

Example of Engage Setpoint

The Engage Setpoint for a particular sample may be empirically deter-
mined. Procedures are as follows:

1. Set the Engage Setpoint to 1.0 and engage on the sample. 

2. After engagement, make note of the Setpoint parameter. 

3. While watching the scan, adjust the Setpoint value until the tip 
tracks the surface correctly. Calculate the following: 

- Setpoint value/ Starting Setpoint value = Engage Setpoint 
(For optimal value, take the average of several engages on a selec-
tion of samples or different areas of the same sample).

Bidirectional scan When the Bidirectional scan parameter is Enabled, data from both Trace and 
Retrace scans are used to capture frames in half the normal time. Images 
have alternately shifted lines, which cause features to lose some of their lat-
eral definition; however, data may be used for metrological analysis. Use to 
save time while capturing images.

Range or Settings: 

Enabled or Disabled

When Enabled, features shown in images lose some lateral definition, mak-
ing point-to-point measurements inadvisable. Vertical data, however, is unaf-
fected.

Use the Scan line shift parameter to readjust images with the Bidirectional 
scan parameter Enabled. This will shift scan lines relative to one another to 
restore some lateral definition in features.

Scan line shift Use the Scan Line Shift parameter to shift trace and retrace lines relative to 
one another by up to 5 pixels in either direction. Units are in pixels and range 
from -5 to +5. Scan line shift is used for readjusting images captured when 
the Bidirectional  scan parameter is Enabled.

Range or Settings: -5 to +5

This parameter is generally only for images that have been captured with the 
Bidirectional scan parameter set to Enabled.

Tip Serial Number Saves input in the image header (Ciao Scan List) for users who keep a tip fil-
ing system. This is to keep track of the tips used for certain images. 

Serial Number: Scanner Calibration  file.
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Min. Engage Gain 
(STM only)

Allows user to engage tip in constant height mode. In constant height mode, 
the gains (feedback) is disabled. However, the Min . Engage Gain parameter 
provides for gain during engagement.

Strip Chart Rate Frequency of (Z-position, deflection) data point acquisition.

Range: 32kHz

Typical value: 1kHz

Strip Chart Size Time interval over which (Z-position, deflection) data points are displayed.

Typical value: Tens of seconds.

Note: Although the strip chart collects and displays data over the time inter-
val defined by clicking Start, then later, Stop, this data is not saved for sub-
sequent use until the Capture icon is clicked. If Capture is clicked while 
strip chart data is being taken, what is saved begins at the start of the chart 
(sooner than the icon is clicked).
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Auto  Gain

Auto Gain automatically sets the feedback parameters (Proportional  and Integral gain) for a 
given sample. 

Auto Gain works by analyzing the difference between Trace minus Retrace (TMR ). The analysis 
is used to choose a set of feedback parameters that minimizes the TMR  value. By specifying the 
starting value of the Integral gain sweep, the ending value, and the size of the increments, Aut
Gain may be used to calculate a set of useful feedback parameters.

For the purposes of this analysis, Proportional  gain operates as a factor of Integral  gain. The 
relationship is , where F is a factor defined as Pro. Gain factor. 

Auto Gain only requires the input of the three Gain values in order to calculate an effective 
Integral gain.

Parameters in the Auto Gain Panel: 

Gain start The starting value of the integral gain sweep.

Range or Settings: Recommended settings are 0.10 for TappingMode, 0.5 
for Contact Mode.

Gain end The ending value of the integral gain sweep.

Range or Settings: Recommended settings are 1.0 for TappingMode, 10.0 
for Contact Mode.

Gain incr. The increment step for each integral gain test.

Range or Settings: 0.0 to 5.0; Recommended settings are 0.1 for Tapping-
Mode, 0.5 for Contact Mode.

Pro. Gain factor Proportional gain is set to: 

Range or Settings: 0.0 to 10.0; Recommended value is 1.50

Max shift The percentage of pixels to shift the Retrace line to match the trace line dur-
ing the correlation routine. The more closely the Trace and Retrace lines 
match, the lower the TMR will be, and the more effective the Auto Gain fea-
ture.

Range or Settings: 0 to 0.2; recommended setting is 0.02 (or 2%)

Gain offset Specifies the number that determines the final, best fit Integral gain. Allows a 
change in the value produced by Auto Gain. 

Range or Settings: 0.0 to 2.0; recommended setting is 0.95 (or 95%)

Lines/gain The number of lines to test and average for each integral gain step. Optimal 
settings are between 4 and 8. This, like Max shift, allows for a more accurate 
determination of TMR. 

Range or Settings: 1 to 20, with a default setting of 8

Proportional gain F Integral gain×=

Pro. Gain factor Integral gain×
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3.3 Tips on Using Realtime

Please refer to the following Realtime commands available on the NanoScope software:

• Using the Image Interface Section 3.3.1

• Multiple Channels Section 3.3.2

• Hints to Optimize the Engage Button Section 3.3.3

• Scan View Parameters Tips Section 3.3.4

• Channels Parameters Tips Section 3.3.5

• Feedback Parameters Tips Section 3.3.6

3.3.1 Using the Image Interface

There are various commands available for use during a Realtime scan. Below is a descriptio
these commands (see Figure 3.3a).

Figure 3.3a   Image for Processing
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Buttons

• Measure: Allows you to draw a line to make measurements.

• Pan: From a zoomed image, the user can pan around to other areas of the origina
image.

• Data Zoom: Left-click, hold, and drag out a box. Release the mouse button and the
image will automatically zoom in to the area of the box. The original scan size rem
the same.

• Zoom: Allows you to zoom in on a region of interest. 

• When you select Zoom a bounding box appears on the image display. Left-click 
the outer edge of the box to resize. 

• Left-click in the center to reposition. 

• Click the Execute button to zoom in. This updates the Scan size and X and Y 
Offset parameters.

• Execute: Executes the Zoom and Offset commands. You must select the Zoom or 
Offset button for the Execute button to appear.

• Offset: Allows you to center the scan at the region of interest. 

• When you select Offset a crosshair displays at the center of the image.

• Left-click and hold the crosshair to reposition it.

• Click the Execute button to center the scan. This updates the X and Y Offset 
parameters.

Right-Clicking on the Image

By right-clicking on the image, you will get a menu that allows you to perform the following ta

• Copy Clipboard: Copies the image to the Microsoft™ clipboard.

• Tooltip Info Level:

• Basic

• Medium

• Advanced

• None
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Right-Clicking on the Color Bar

Right-clicking on the color bar along the right side of the image (see Figure 3.3a) will produce a 
Color button (see Figure 3.3b). Clicking on this Color button will open the Image Adjust menu, 
where you can perform the following image adjustments (see Figure 3.3c):

Figure 3.3b   Color Button

a.  You can adjust the color by changing the Contrast or Offset settings.

• Contrast—Number (-10 to +10) designates contrast of colors in displayed imag
(e.g., 0 shows little change, while 10 shows highest contrast).

• Offset—Number (-128 to +128) designates offset of colors in displayed image (e
120 shows illuminated background on image).

b. Clicking the Color Reset button will change all the current readings to the default 
settings.

Figure 3.3c   Image Adjust Menu

c. To change the color table, position the mouse over the color bar on the right side 
image. Click and hold the left mouse button, then drag the mouse from left to right
scroll through the different color tables.

 Using the Mouse Within a Captured Image in Measure Mode

Left-click anywhere in image 
window, drag line out, and 
release

Creates a line of X length, at Xo of angle in the image window.

Place cursor on line Displays length and angle values of line in the image window.

Place cursor on line, click 
and hold left button, and 
drag

Allows you to drag the line anywhere in the image window.
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Figure 3.3d   Image Cursor Menu

Using the Grid Display

Measurement cursors for the Scope View are provided to the left and right of the Grid Display. Yo
can bring the cursors into the grid by placing the mouse cursor onto the measurement curso
clicking and holding the left mouse button, and dragging them onto the grid. When you place
mouse cursor onto a measurement cursor, the cursor will change from a plus sign to a horizo
vertical arrowhead cursor, which indicates you can grab and drag this cursor.

Click and hold on either end 
of line and drag

Changes length and/or the angle of the line.

Right-click Clicking the right mouse button when the cursor is on the line 
accesses the Image Cursor menu (see Figure 3.3d).

• Delete—Deletes the line.

• Flip Direction—Switches the line end to end.

• Show Direction—Adds small arrowhead to the line to 
indicate its the direction.

• Set Color— Allows you to changes the color of the 
line.

• Clear All—Deletes the line.
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Right-clicking on the grid will bring up the Grid Parameters menu (see Figure 3.3e) and allow 
you to make the following changes:

Color Allows operator to change the color of the:

• Curve (data)

• Text

• Background

• Grid

• Minor Grid

• Markers

Filter Typically used for a Profiler Scan.

• Type—Allows the user to plot the mean, maximum or 
minimum y-value per x-value.

• Points —Allows user to plot multiple vertical axis 
(y-)values at each horizontal axis (x-)value. Select 4K, 
8K, 16K or 32K Points to limit the display to 4, 8, 16 
or 32 times 1024 points.

Minor Grid Places a minor grid in the background of the Vision Window.

Scale Allows user to auto scale, set a curve mean, or set their own data 
range

Translate Offsets the curve by the placement of a horizontal cursor on the grid

Line Style For each curve, the operator can choose a connect, fill down, or point 
line.

User Preferences Restore—Reverts to initial software settings

Save—Saves all changes operator has made during this session. This 
becomes the new default settings.

Copy Clipboard Copies the grid image to the Microsoft Clipboard

Print Prints out the current screen view to a physical printer

Export Exports data in bitmap, JPEG or XZ data format

Active Curve Determines which curve you are analyzing
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Figure 3.3e   Grid Parameters

3.3.2 Multiple Channels

It is often helpful to view more than one channel of data simultaneously. Scan-Dual and Scan-
Trip le can be selected upon first opening Realtime by clicking on the appropriate check boxe
the Add Views to Realtime1 dialog box (see Figure 3.3f). 

Figure 3.3f   Add Views to Realtime1 Dialog Box

If you are already in Realtime, you can also access multiple channel views by right-clicking o
Realtime icon in the Realtime workspace (see Figure 3.3g).

• Click Add View > Scan-Dual to add a window with two channels displayed.

• Click Add View > Scan-Triple to add a window with three channels displayed.

Note: To open a single channel, click Add View > Scan Display.
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Figure 3.3g   Add Views to Realtime1 Menu

Image controls are displayed beneath each image (see Figure 3.3h). 

Figure 3.3h   Scan-Dual View

In Scan-Triple, the Scan Line, Scan Direction, Data Scale, Data Center, Realtime Planefit, and 
Offline Planefit settings are not displayed below the images and must be accessed using the
parameters list to the right of the image display (see Figure 3.3i).

Realtime Icon
in Workspace

Scan Controls
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Figure 3.3i   Scan Triple Dialog Box and Location of Channel 2 and 3 Parameters

Note: All three channel display options are included among the Realtime views 
presented as options to include in the workspace upon first opening the 
Realtime workspace (see Figure 3.3h).

Typical examples of the use of multiple channels:

• To simultaneously monitor both a TappingMode height image and a phase image o
same region.

• To simultaneously collect a topography and MFM image.

3.3.3 Hints to Optimize the Engage Button

• When used with stepper-motor-engagement microscopes, the tip is lowered under
program control. While the tip is being engaged, the tip travel distance is shown in
center of the status bar on the Control Monitor. When the surface is detected, the 
workstation beeps, starts the Realtime imaging process, and displays Engaged in the 
status bar on the Control Monitor.

• During automatic engagement, the tip will travel a preset distance (200µm for 
Dimension AFMs, 125µm for MultiMode AFMs). If the sample surface is not detect
in this distance, an error message will be displayed.

• If the tip is on the surface and the Z center voltage indicates that the piezo is near 
extension or retraction, the tip may be withdrawn and re-engaged to center the Z c
voltage. Alternatively, the Tip Up and Tip Down subcommands of the Motor  command 

Channels 2 and 3 Parameters
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can be used to center the Z voltage. If the Z center position indicates that the scan
retracted, click the Tip Up button until Z center is near 0V (0.50V).

• Pressing Ctrl-F after the Engage command has been executed will cause a false eng
to occur after the SPM safety height is recycled for Dimension, causing the Realtim
software to start scanning independently of whether the surface has been detected

3.3.4 Scan View Parameters Tips

Optimizing the Scan Size Parameter

• The Scan size and offsets can be set by using the Zoom and Offset subcommands in 
Scan View or in tabbed panels.

• Non-zero X and Y offsets reduce the maximum Scan size. Each volt of X or Y offset 
reduces the maximum scan size by 2V.

• Having a non-zero Scan angle will reduce the maximum allowable Scan size.

• The maximum Scan size will also decrease as the Scan rate increases.

Optimizing the X Offset, Y Offset Parameter

• These parameters use the sample as the position reference. Therefore, a more negX 
offset value will move a feature in the current image to the left on the Image display 
Similarly, a more negative Y offset moves a feature in the current image down on the 
Image display.

• Using the left-arrow and right-arrow keys when the cursor is in these parameters w
decrement and increment these parameters by 10% of the Scan size.

• Using the Zoom or Offset subcommands on the automatically changes the value of X 
and Y offsets.

Optimizing the Scan Size and Scan Rate Parameters

• The Scan size and height of features on the sample will affect the maximum Scan rate 
that should be used on a given sample. Scan rate should be set to a rate that allow
tip to closely track the sample surface in both trace and retrace. In general, larger 
and taller features require slower scan rates.
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3.3.5 Channels Parameters Tips

Optimizing the Data Type Parameters

• The system can display up to three Realtime images on the Display Monitor.

• The Data type parameter does not switch the operating mode of the instrument, it 
simply changes the source of the data displayed. 

Optimizing the Data Scale Parameters

• Data beyond the setting of the Data scale is clipped for the Realtime display. Captured
data, however, is not clipped. Independent of the settings of this parameter, the cap
data will be correct unless it exceeds the maximum vertical range of the scanner.

• Each Data type retains separate settings for Data scale.

• Data Center is used to manually offset the trace data when Realtime Planefit is se
none.

The conversion of volts to nm or nA, is dependent on the value Sensitivity Detector parameters in 
the Tools > Calibrate > Detector panel.

For example, nanometers of cantilever deflection are calculated using the Sensitivity parameter in 
the Force Calibrate panel.

Optimizing Realtime Planefit Parameters

The setting of Realtime Planefit only affects the displayed data. It does not affect the captured d
The parameters are described below.

• None displays the raw data in the scope display.

• Offset applies a zero order correction to each line of data so that the average heig
the line is centered in the scope display.

• Line applies a 1st order correction, removing both tilt and offset from each line of da

Note: If features are not evenly spaced along the scan line, using Realtime Planefit 
Line can result in artificial tilting of the scan line.

Optimizing the Offline Planefit Parameter

• The None option should only be used in special cases. The Offset and Full  options 
provide greater dynamic range in the data to reduce round-off and other errors in 
subsequent calculations.

• The Offline > Modify > Flatten and Planefit commands can also be used to level the
data after it has been captured.
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3.3.6 Feedback Parameters Tips

Optimizing the STM Feedback Parameters

• The Boost and Log modes are preferable for most STM samples, because the tip 
responds in a more symmetric manner (i.e., the same going up and coming down)Log 
and Boost modes tend to linearize the entire feedback loop since Z ≈ ln(i). The 
asymmetric response of the Lin  setting distorts data.

• Use of Boost mode allows the Proportional gain and Integral gain values to be 
reduced and is preferable for large scans having high, vertical features (e.g., integ
circuits).

• When Boost mode is selected, the Integral  and Proportional gains are often best set to 
lower values than when Log mode is used.

Optimizing the Integral and Proportional Gain

• The Integral gain is usually the major contributor to the performance of the feedbac
loop due to its “long term” influence. For this reason, it is usually adjusted before 
proportional gain.

• The integral term in the feedback calculation has the highest gain at low frequenci
and its effects diminish with increasing frequency.

• A nominal Integral gain value may be obtained by slowly increasing the value until t
piezo begins to oscillate, then decreasing the value until oscillation ceases. Oscilla
effects are best viewed using Scope Mode and show up first in error signal (i.e 
deflection or amplitude).

• The Proportional gain parameter is typically set to 35 to 100% more than the Integral  
gain value.

Optimizing the Look Ahead Gain Parameter

• Look ahead gain adds information from the previous scan line to the feedback loop
calculation, so it is most useful for samples with long features oriented perpendicu
the scanning direction.

• Use Look ahead gain discreetly. For many surfaces, 0.5 to 0.8 is nominal.
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3.4 Force Curves

Force Curves ramp tip-sample separation while holding the X, Y position constant in the cente
the previous scan. The scanner’s vertical position is plotted versus either the cantilever defle
(Contact AFM), or the amplitude of the cantilever oscillation (TappingMode). Alternatively, the
cantilever deflection or oscillation amplitude can be plotted relative to a user-designated inpu
signal.

3.4.1 Force Curves Procedure

Ramp Settings

To obtain force curves, it is necessary to first engage in Scan Mode using one of the Scan Views 
(see Preparing a Dimension Series AFM for a Realtime Scan Section 2.4.2), then switch to 
Ramp mode. If you want to calibrate deflection sensitivity, use a hard sample in the following
procedure.

1. Activate Ramp mode (this causes the system to stop scanning, and the probe to positi
above the center of the previous image):

a. Click the Ramp node in the workspace or any visible ramp plots.

                              Or

b. Add the Ramp Parameter List and Ramp Plot(s) to the workspace. Right-click 
Realtime or click the Acquire menu, and select Ramp Parameter List and Ramp 
Plot. It is possible to view three Ramp Plots at a time by adding ramp plots to the 
workspace. Arrange the Ramp Plot(s) and Ramp Parameter List so that all are 
viewable.

Note: See Ramp Parameter List Section 3.4.2 - Feedback Panel Section 3.4.7 for a 
thorough discussion of the Ramp Parameter List Parameters. When in Ramp 
mode, a ramp- specific menu also displays, the Ramp menu. See Ramp Menu 
Section 3.4.8 for more information.

2. Enter the following parameter settings in the designated panels of the Ramp Parameter 
List :

a. In the Ramp panel select:

Parameter Setting

Ramp output Z

Ramp size 1.00µm
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b. In the Channel 1 panel select:

Gather Force Curves

1. Select Ramp > Run continuous from the menu bar.

2. While watching the Ramp View and the Display Monitor’s bar graph (see Figure 3.4a), 
increase the Z Scan Start to move the tip closer to the sample.

Figure 3.4a   Bar Graph

3. When the force curve suddenly rises, the tip has reached the surface (see Figure 3.4b).

Z scan start 0nm

Scan rate 1.00Hz

Number of samples 512

Parameter Setting

Data Type Deflection

X Data Type Z

Display Mode Deflection vs. Z

Parameter Setting
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Figure 3.4b   Force Curve

4. Click the Capture icon to save the force curve. Make note of the file name in the status 
(lower right corner of the window).

Calibrate Deflection Sensitivity

It is often necessary to calibrate the deflection sensitivity of a force curve. The deflection sens
depends upon several factors, such as the position of the laser spot on the cantilever, so it n
be calibrated each time you change the probe. Use the following procedure to determine the
deflection sensitivity:

1. Move two cursors onto the Deflection vs. Z plot (see Figure 3.4c).

Figure 3.4c   Realtime Force Curve

2. Arrange the cursors so that they surround the contact (steepest) portion of the graph 
(see Figure 3.4d).
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Figure 3.4d   Force Curve Cursors

3. Select Force > Update Sensitivity. The software will automatically calculate the deflectio
sensitivity.

Figure 3.4e   Update Sensitivity

4. Click OK  to accept this deflection sensitivity in the dialog box that displays, and it will 
automatically be entered into the Sens. DeflSens parameter in the Channel Data panel to the 
right of the plot (see Figure 3.4c).

Figure 3.4f   Deflection Sensitivity Dialog Box

5. Replace the hard sample with the sample you wish to analyze. The deflection sensitivit
remain applicable as long as the position of the laser spot on the cantilever does not ch
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3.4.2 Ramp Parameter List

When you open Ramp Parameter List, the Ramp Parameter List box displays (see Figure 3.4g). 
All force curve parameters can be set in the Ramp Parameter List. The Ramp Parameter List is 
sectioned into seven panels. The parameters in each panel are defined in the following secti

• Ramp Panel on page 94

• Mode Panel on page 96

• Auto Panel on page 97

• Channel (1, 2 or 3) Panels on page 98

• Feedback Panel on page 99
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Figure 3.4g   Ramp Parameter List
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3.4.3 Ramp Panel

Ramp Output: Specifies the Ramp Channel.

Ramp Size: Specifies the range of the Ramp Channel. Visible only if the Ramp Channel 
parameter is set to Z. Settings depend on the specified units.

Z Scan Start: Visible only if the Ramp Channel parameter is set to Z and TRIGGER MODE is OFF. 
Z scan start is the bottom position of the Z-axis scan as represented on the Display Monitor’s
graph. When the Force Calibrate command is first accessed during imaging, this value is 
automatically set to the Z Center Position.

Note: The value of this parameter will need to be increased to move the sample c
to the cantilever in the case where there is no deflection of the cantilever fo
displacement of the sample.

• Range and Settings: The range of this parameter depends on the scanner. The units
this parameter are volts or nanometers, depending on the setting of the Units parameter.

Note: While the user is ramping Z in Force Calibrate, the feedback parameters (i.e.
type, count and value) are inactive.

Scan Rate: The Scan Rate sets the ramping rate. Changing this value effects the Forward and
Reverse Velocities.

Forward Velocity: Forward Velocity of the tip (in µm/s) as it approaches the surface. Increasin
this value increases the Scan Rate.

Reverse Velocity: Reverse Velocity of the tip (in µm/s) as it retracts from the surface.

X Offset: Controls the position of the range in the X direction.

Y Offset: Controls the position of the range in the Y direction.

Number of samples: Number of data points collected during each upward (retraction) and 
downward (extension) travel cycle of the piezo. The Number of samples parameter sets the 
density of the force curve. This parameter does not change the Z scan size.

• Range or Settings: 4 to 64,000 data points displayed per extension and retraction cyc
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Spring Constant: Records the spring constant of the cantilever that is currently being used. T
parameter is input by the user and is recorded along with each force plot captured. It is used
Offline analysis of the force plot. It is not critical to set the Spring constant in Realtime, since it 
can be altered in the Offline analysis of the captured force plot. The Spring constant is neces
display a graph of force vs. separation if UNITS is set to FORCE.

Plot Units: Switches parameters in the control panels between units of Volts (V), Metric (nm o
µm), or Force (nM). Changing this parameter also changes the setting of the Units parameter on the 
AFM control panel.

• Range or Settings: Volts (V), Metric (nm) or Force (nN)

Display Mode: The portion of a tip’s vertical motion to be plotted on the force graph.

• Range or Settings:

• Extend—Plots only the extension portion of the tip’s vertical travel.

• Retract—Plots only the retraction portion of the tip’s vertical travel.

• Both—Plots both the extension and retraction portions of the tip’s vertical trave

• If a channel other than Z is chosen, Display mode will not be available in Offline 
view.

X Rotate: Allows the user to move the tip laterally, in the X direction, during indentation. This 
useful since the cantilever is at an angle relative to the surface. One purpose of X Rotate is to 
prevent the cantilever from plowing the surface laterally, typically along the X direction, while
indents in the sample surface in the Z direction. Plowing can occur due to cantilever bending 
indentation or due to X movement caused by coupling of the Z and X axes of the piezo scan
When indenting in the Z direction, the X Rotate parameter allows the user to add movement to 
scanner in the X direction. X Rotate causes movement of the scanner opposite to the directio
which the cantilever points. Without X Rotate control, the tip may be prone to pitch forward durin
indentation. Normally, it is set to about 22.0º.

• Range or Settings: 0 to 90º; most effective values are between 15 and 25º.
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3.4.4 Mode Panel

Tr igger Mode: Limits the amount of force exerted by the tip upon the sample. It is possible to
operate the trigger independent of drift (Relative) or at some arbitrarily fixed point (Absolute)
depending on the trigger settings.

Data Type: Channels may be assigned for triggering to any input signal available including: 
Deflection, Amplitude , Phase or Friction  data.

Trig Threshold: The value of the cantilever deflection, as measured by the photodetector, de
for the indentation or scratch. The Tr igger threshold defines the maximum force applied to the 
sample corresponding to the upper right-most point on the force plot.

• Range or Settings: -10V to +10V, depending on the Deflection Limit . Try 0.5V to 1.0V.

Trig  Direction: Determines the direction of the trigger and allows for a Positive, Negative, or 
Absolute trigger slope. In this way, the trigger may be configured to activate on either the pos
or negative direction of the force curve.

 

Start Mode: Start mode allows you to switch between the various force modes without returnin
image mode. 

• Range or Settings:

• CALIBRATE —Produces standard Force Mode force plots. Includes the ability to
continuously cycle the tip up and down.

• STEP—Produces standard Force Mode force plots, with added control to step the 
tip towards the surface.

• MOTOR STEP—Tip is stepped towards surface using the motor.

End Mode: Determines the location of the tip when the microscope is returned to Image mod
Choices include Extended, Retracted, or Surface.

Z Step Size: The change in tip height per step when using force step.

Negative Trigger Direction Positive Trigger Direction

Z position - 0.10 µm/div Z position - 0.10 µm/div
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Auto Start: When enabled, autostarts Force mode when entering from Image mode. If off, you 
must start ramping by clicking the Continuous or Single icon, or by selecting the proper menu 
selection under the Ramp menu.

Surface Delay: Specifies a delay when the tip reaches the point closest to the sample.

• Range or Settings: 0 to 200 seconds

Retracted Delay: Similar to Surface delay, this value specifies the duration of the delay when t
piezo is at the top of the cycle (farthest away from the sample).

• Range or Settings: 0 to 200 seconds

Auto Offset: Because of Z drift (thermal drift, piezo drift, etc.), the sample will sometimes drift 
of Z range. When enabled, Auto Offset uses the Setpoint value from Image mode to Feedback 
find the surface and resume Force imaging. The Auto Offset feature is a form of drift correction.

Strip Chart Rate: Frequency of (Z-position, deflection) data point acquisition for strip chart (o
available for Picoforce and Nanoman).

• Range: 20kHz to 0.01Hz. Typical value: 1kHz

Strip Chart Size: Time interval over which (Z-position, deflection) data points are displayed in
strip chart.

• Typical value: 10 to 10,000 sec.

Note: Although the strip chart collects and displays data over the time interval defi
by clicking Start, then later, Stop, this data is not saved for subsequent use 
until the Capture icon (shown) is clicked. If Capture is clicked while strip 
chart data is being taken, what is saved begins at the start of the chart (so
than the icon is clicked).

3.4.5 Auto Panel

The Auto Panel parameters are only available when Autoramping.

Columns: Number of points in the Y axis.

Rows: Points in the X axis.

Column Step: Offset distance between points in the X direction.

Row Step: Offset distance between points in the Y direction.

Threshold Step: The trigger point at which the deflection or the current activates the position 
change.
Rev. D Nanoscope Software 6.13 User Guide 97



Realtime Views
Force Curves

98

 the 

the X-

lot.

sa.

with 

 
en 
e 
ch 
Capture: State is either enabled or disabled. When enabled, the software records and stores
ramp data for each data point in the matrix of rows and columns.

3.4.6 Channel (1, 2 or 3) Panels

Data Type: Channels may be assigned to any input signal available including: Deflection, 
Amplitude , Phase, Friction  and so on. Any channel may be switched to Off, however, at least one 
channel is always on.

X Data Type: Type of data that the channel data is being compared to. This data displays on 
Axis of the scope grid.

Data Scale: Voltage range for the vertical axis of the force curve plot. 

Note: This can be overridden by setting Autoscale On for the plot.

Data Center: Offsets centerline of scan by the amount entered. 

Note: The Data center offset does not become a permanent part of the data.

• Range or Settings: Depends upon the input signal, generally ± one-half of data scale 
maximum.

Deflection Sens.: Defines the conversion factor from cantilever deflection signal voltage to 
nanometers of cantilever displacement (in nm/V) using data in the contact region of a force p

Plot Invert : Inverts data along the Y-axis, effectively turning valleys into mounds and vice ver

Ave. Points: Averages multiple points to smooth the curve.

Effective BW: A display (you cannot input a value to it) representing the sampling frequency 
display averaging taken into account:

                     Effective BW = (force plot sampling rate)/(Ave. Points)

Phase Offset: Shift horizontal position of plot to compensate for averaging of endpoint data.

Note: The numerical values of the two Phase Offset parameters can be ignored; set
them to whatever values minimize the apparent hysteresis. Particularly wh
Forward Velocity and Reverse Velocity are unequal, the same numerical valu
for each Phase Offset may not correspond to an identical displacement on ea
axis.

Display Mode: The portion of a tip’s vertical motion to be plotted on the force graph.

Range or Settings:

• Extend—Plots only the extension portion of the tip’s vertical travel.
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• Retract—Plots only the retraction portion of the tip’s vertical travel.

• Both—Plots both the extension and retraction portions of the tip’s vertical travel.

• If a channel other than Z is chosen and the force curve is captured Offline, Display 
mode may not be available in Offline view.

X Rotate: Allows the user to move the tip laterally, in the X direction, during the ramping of Z.
This is useful because the cantilever is at an angle relative to the surface. One purpose of X Rotate 
is to prevent the cantilever from plowing the surface laterally, typically along the X direction, w
it indents in the sample surface in the Z direction. Plowing can occur due to cantilever bendin
during indentation or due to X movement caused by coupling of the Z and X axes of the piez
scanner. When indenting in the Z direction, the X Rotate parameter allows the user to add 
movement to scanner in the X direction. X Rotate causes movement of the scanner opposite to 
direction in which the cantilever points. Without X Rotate control, the tip may be prone to pitch 
forward during indentation. Normally, it is set to about 22.0º. 

Range or Settings: 0 to 90 degrees; most effective values are between 15 and 25º.

3.4.7 Feedback Panel

Only the Force Curve-applicable menu parameters are described below:

Deflection Setpoint: Defines the deflection signal, and therefore the tip-sample force, maintain
by the feedback loop.

• Range or Settings: ± 10.0V maximum

Deflection Limit: Use this parameter for attenuating the input voltage signal (appears only wh
performing Contact AFM).

• Range or Settings: 2.500V for regular imaging and 20.00V in Force Mode only

3.4.8 Ramp Menu

While the microscope is engaged and in Realtime mode, opening the Ramp parameters will display 
the Ramp Menu.
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Figure 3.4h   Ramp Menu

Ramp Menu Definitions

Run Continuous: The tip is continuously lowered and raised by a distance equal to the Ramp size. 
This is the normal, default motion during Force Calibrate. “Raising” and “lowering” are relative 
to your system (e.g., On Dimension Series SPMs, the tip is raised and lowered to the surface
however, other SPMs raise and lower the sample beneath the tip).

Run Single: Lowers and raises tip once by a distance equal to the Z scan size, then halts.

External Trigger : (Not available)

Stop: Halts all tip movement.

Retract: The Z-axis piezo retracts to its limit in preparation for Approach Continuous. This 
command does not initiate motor movements.

Approach Continuous: The tip lowers to the surface and raises in a controlled series of steps,
indexed by the Z step size (see Scan Mode panel) distance. This process continues downwa
the tip encounters the surface. When tip deflection exceeds the Threshold Step amount, Approach 
Continuous halts and the resulting force curve displays.

Approach Single: The tip is lowered to the surface and raised in a single, controlled step. This
process is halted if the surface is encountered by the tip, causing deflection exceeding the S
threshold amount. The resulting force curve is displayed.

Note: For both Approach Continuous and Approach Single, if Start mode = 
MOTOR STEP, the motor is stepped towards the surface, not the Z piezo.

Auto ramp: Begins auto ramping as defined by the parameters specified in the Auto Panel.
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The Analysis commands relate to analyzing the surface behavior of materials on images captu
Realtime mode. These commands are known as image processing or analysis commands. T
commands contain views, options and configurations for analysis, modification, and storage 
collected data. The analysis may be automated (i.e., in autoprograms) or completed manual
general, the analysis commands provide methods for quantifying the surface properties of sa

Please refer to the following analysis commands available in Analyze menu of the NanoScope 
software:

• Image:  Section 4.1

• 3D Surface Plot:  Section 4.2

• Zoom:  Section 4.3

• Depth:  Section 4.4

• Power Spectral Density:  Section 4.5

• Roughness:  Section 4.6

• Section:  Section 4.7

• Step:  Section 4.8

• Widt h:  Section 4.9

• XY Drift: Section 4.10

• Multiple Channel Analysis:  Section 4.11

• AutoProgram:  Section 4.12
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4.1 Image

The term Image refers to the data captured in Realtime mode. The current image processing 
capabilities include data analysis, modification, presentation and storage of the images. The 
of the image includes: 

• Data captured in Realtime scanning mode

• New image files created using modification or analysis commands

For general information on the interface and basic functions in image processing, see Using the 
Image Interface: Section 4.1.1.

4.1.1 Using the Image Interface

To process an image, you must open an image file. This can be done by:

• Clicking File > Open. When the Open NanoScope File dialog box opens (see Figure 
4.1a), select Captured File (*.*) and click the Ok button.

Figure 4.1a   Open NanoScope File Dialog Box

• Double-click an image in the Browse dialog box. The new image appears in the clien
window (see Figure 4.1b).
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Figure 4.1b   Image for Processing

Directory icons appear in the browse window. Double-click a folder icon to browse that direct
(see Figure 4.1c).

Figure 4.1c   Directory Icons

Directory Folder Icon

Capture Directory Icon
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Selecting the first icon in the upper left of the file browsing window initiates a text presentatio
file information (as in Figure 4.1d). The second icon in the upper left of the file browsing window
causes thumbnail presentation of image files as illustrated in Figure 4.1b (the icon has been scrolled
out of view at the top of the window of images). Click on a thumbnail to open the image for fu

analysis. The Capture Directory icon  in the upper left of the file browsing window display

file information, in either text or thumbnail presentations, of the capture directory (default is 
D:\capture).

Figure 4.1d   Browse for Folder Window Open Upon Clicking Directory

You can change the current capture directory in the Capture File dialog box by selecting 
REALTIME  > CAPTURE FILENAME , shown in Figure 4.1e.

Figure 4.1e   Capture File Dialog Box
4 Nanoscope Software 6.13 User Guide Rev. D



Analysis Commands
Image

Re

on) 
dow. 
Image Display

If no images are selected, right-clicking in the image browse window (but not on an image ic
allows you to select a display channel and a color table for the image icons in the browse win
See Figure 4.1f.

Figure 4.1f   Selecting the Display Channel and Color Table for the Icons
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Exporting Images

You may export images, in either bitmap or JPEG formats, from the image browse window b
right-clicking single or multiple images, shown in Figure 4.1g. You may select the channel and a 
color table.

Figure 4.1g   Exporting Multiple Images from the Image Browse Window
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The Offline Add View menu for image processing differs from the Realtime Add View commands. 
The commands include measurement, analysis and modification commands (see Figure 4.1h).

Figure 4.1h   Image Processing Functions Menu
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Right-Clicking on the Image

By right-clicking on the image, you will get a menu (see Figure 4.1i) that allows you to perform the 
following tasks:

Figure 4.1i   Image Click

• Rotating Line—Left-click, hold, and drag out a line. Release the mouse button to e
the line.

• Box (for some analyses)—Left-click, hold, and drag out a box and release the mou
button.

Note: Left-clicking in the center of the box allows you to translate. Left-clicking on
edges allows you to change the box size.

• Copy Clipboard—Copies the image to the Microsoft clipboard.

• Tooltip Info Level:

• Basic

• Medium

• Advanced

• None

• Export—Exports the image as a bitmap or JPEG (WYSIWYG), or Full Image (pixel
pixel data).
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Image Buttons

Clicking the Image buttons above the captured image (see Figure 4.1j) performs the following 
functions:

• Data Zoom—Left-click, hold, and drag out a box. Release the mouse button and th
image will automatically zoom in to the area of the box.

• Pan—From a zoomed image, the user can pan around to other areas of the origina
image.

• Measure—Left-click, hold, and drag out a line. Length of line appears in a box near
line any time cursor is on the line.

Right-Clicking on the Color Bar

Right-clicking on the color bar along the right side of the image (see Figure 4.1j) will produce a 
Color Scale button. Clicking on this Color Scale button will open the Color Scale dialog box, 
where you can perform the following image adjustments:

• Contrast—Number (-10 to +10) designates contrast of colors in displayed image (e
0 shows little change, while 10 shows highest contrast).

• Offset—Number (-128 to +128) designates offset of colors in displayed image (e.g
120 shows illuminated background on image).

• Data Scale—Designates the vertical range of the image, corresponding to the full ex
of the color table.

• Table—Designates the Color Table number.

Figure 4.1j   Image Adjustment Controls

Image
Buttons

Color Scale
Menu

Color
Scale 
Dialog Box

Color Bar
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Figure 4.1k   Image Cursor Menu

Left-Click anywhere in image 
window, drag line out, and 
release

Creates a line of X length, at Xo of angle in the image window

Place cursor on line Displays length and angle values of line in the image window

Place cursor on line, click 
and hold left button, and 
drag

Allows you to drag the line anywhere in the image window

Click and hold on either end 
of line and drag

Changes length and/or the angle of the line

Right-Click Clicking the right mouse button when the cursor is on the line 
accesses the Image Cursor menu (see Figure 4.1k)

• Delete—deletes the line.

• Flip Direction—switches the line end to end.

• Show Direction—Adds small arrowhead to the line to 
indicate direction.

• Set Color—Allows you to change the color of the line.

• Clear All—Deletes all lines.
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4.2 3D Surface Plot

The 3D Surface Plot View displays the selected image with color-coded height information in 
three-dimensional, oblique perspective. You can select the viewing angle and illumination ang
a modeled light source. 

You can view the 3D Surface Plot View using one of the following methods:

• Right-click on the image name in the Workspace and select Add View > 3D Surface 
Plot from the popup menu.

                                     Or

• Select Analyze > 3D Surface Plot from the menu bar.

                                     Or

• Click the 3D Surface Plot icon in the upper toolbar. 

The Surface Plot panel appears and allows formatting of image data on the Display Monitor (
Figure 4.2a). 

Figure 4.2a   3D Surface Plot Window
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4.2.1 Parameters in the 3D Surface Plot Inputs

The Projection Type, Plot Type, and Label Type 3D Surface Plot parameters can be changed b
clicking on the related window and selecting from the drop-down menus. The remaining 
parameters may be changed by typing the desired information in the related window or by us
the keyboard and mouse keys. 

• To zoom in or out on the image, hold the control key down and slide the mouse up
down on the image while holding the left mouse button.

• To pan, hold the shift key down and move the mouse up, down, left, or right on the
image while holding the left mouse button.

• Clicking and holding the right mouse button down while moving the mouse left and
right changes the light rotation on the image. This is only available when plot type i
to mixed

• Clicking and holding the right button while moving the mouse up down changes th
light pitch. This is only available when Plot Type is set to Mixed.

The function of the Input parameters are:

Projection Type Select either Parallel or Perspective 

• In parallel mode, the viewing volume does not 
change, which has the affect keeping objects the 
same size as they are projected. This is useful for 
maintaining the size and angle of objects between 
the front and back of the view. 

• In perspective mode, objects appear to get smaller 
the further away they are from the eye. This is how 
the objects are perceived in the real world.

Plot Type Select Height, Wire , or Mixed

• Height displays image with the height values 
encoded according to the color table.

• Wire displays image as a line representation of the 
scanned data.

• Mixed displays a combination of height and 
illumination encoding which is used on the 
displayed image. 

Rotation The Rotation parameter in the Surface Plot Inputs 
changes as the viewing angle in changed by rotating the 
displayed image about the Z axis relative to its captured 
orientation.

Pitch The Pitch parameter in the Surface Plot Inputs changes 
as the viewing angle by manually changing the pitch of the 
Y axis in the three-dimensional Surface Plot image.
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The Export  button allows the operator to export the image in the window to either JPEG or bit
format. The graphic will be stored in the Capture folder.

Light Rotation The Light Rotation  parameter in the Surface Plot Inputs 
rotates the light source in the horizontal plane (along the Z 
axis). This is only available when the Plot Type is set to 
Mixed.

Light Pitch The Light  Pitch parameter in the Surface Plot Inputs 
changes the viewing angle by selecting the pitch of the Y 
axis in the three-dimensional Surface Plot image. This is 
only available when the Plot Type is set to Mixed.

Illumination Weight Selects the percentage of the imaginary light source mixed 
with the color-encoded height information when the Plot 
type is set to Mixed.

Label Type The Label Type parameter in the Surface Plot Inputs 
selects whether labels, axes, and the view/illumination 
controller are displayed with the image.

Current Channel Displays the current channel of multichannel scan dis-
plays.
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4.3 Zoom

Use the Zoom function to extract an image from a large Version 6 image for Version 5 analysis
NanoScope Version 5 software features a number of Analysis functions currently not available in 
Version 6 software. Zoom will produce the largest Version 5 image size possible within the 
bounded region (128 x 128, 256 x 256 or 512 x 512). 

Note: 512 x 512 is the most common image size, and will be used as the examp
throughout the rest of this section.

Note: The image produced by this analysis is Version 5 compatible, however, if th
image is later processed by a Version 6 analysis, the image may no longer
Version 5 compatible.

4.3.1 Zoom Procedure

Use the Zoom analysis to isolate a 512 x 512 portion of a high resolution image.

1. Open a large Version 6 image (larger than 512 x 512).

2. You can view the Zoom View using one of the following methods:

• Right-click on the image name in the Workspace and select Add View > Zoom from 
the popup menu.

                                     Or

• Select Analyze > Zoom from the menu bar.

                                     Or

• Click the Zoom icon in the upper toolbar.  

3. The selected image opens in the Zoom dialog box (see Figure 4.3a).
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Figure 4.3a   Initial Zoom Dialog Box

4. A bounding box appears in the image (see Figure 4.3a). Place the cursor inside the box, and
while holding the mouse button, move the box to the location of interest. The box is 
restricted to the largest possible Version 5-compatible image size (usually 512 x 512).

5. Once the box is in place, select the New File Name button. Select a location and name for th
new image. 

6. Select the Create Image button. 

a. If the Auto Open New File parameter under Inputs is set to Yes, the image opens in the
default image view (see Figure 4.3b).

Bounding
Box
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Figure 4.3b   New Zoom Image Dialog Box

b. If the Auto Open New File parameter under Inputs is set to No, The new image will be 
saved in the designated directory but will not automatically display.

7. Use this new image for Version 5 analysis.
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4.3.2 Zoom Interface

Input Parameters

Results Parameters

Zoom Buttons

New File Name Displays the path of the extracted image file. 

Auto Open New File Settings:

• If Yes is selected, after selecting the Create Image button the 
newly extracted image open. 

• If No is selected, the new file will be created and saved in the 
designated directory, but will not automatically display.

Method Settings:

• INTERPOLATE—Data points will be interpolated to create 
new image.

• Replicate—Data points will be used as is to create a new 
image.

V5 Compatible YES. The largest possible V5 compatible file (512 x 512) is created 
from the image.

Number of x Points Number of x points in the new image.

Number of y Points Number of y points in the new image.

Aspect Ratio Aspect ratio of the new image.

Scan Size Scan size of the new image. The units of this parameter are volts if the 
Units parameter (Other Controls panel) is set to Volts. The units are 
linear distance (nm or µm) if the Units parameter is set to Metric .

Error Possible errors:

• No Error —(Default)

• Not Enough X Points—Original image has less than 512 
points/line.

• Invalid Aspect Ratio—Zoomed image results in an aspect 
ratio greater than 256:1.

• File Write—A disk error occurred.

• Unknown—An unknown error has occurred.

New File Name Browse for the location to save the new image.

Create Image A Version 5 compatible image is created from the portion of the high 
resolution image that is contained in the bounding box.
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4.4 Depth

To analyze the depth of features you have numerous choices which measure the height diffe
between two dominant features that occur at distinct heights. Depth was primarily designed for 
automatically comparing feature depths at two similar sample sites (e.g., when analyzing etch
depths on large numbers of identical silicon wafers).

Refer to the following sections on Depth analysis:

• Depth Theory: Section 4.4.1

• Depth Procedures: Section 4.4.2

• Depth Interface: Section 4.4.3

4.4.1 Depth Theory

The Depth command accumulates depth data within a specified area, applies a Gaussian low
filter to the data to remove noise, then obtains depth comparisons between two dominant fea
Although this method of depth analysis does not substitute for direct, cross-sectioning of the
sample, it affords a means for comparing feature depth between two similar sites in a consis
statistical manner.

The display screen includes a top view image and a histogram; depth data is displayed in the
window and in the histogram. The mouse is used to resize and position the box cursor over th
to be analyzed. The histogram displays both the raw and an overlaid, Gaussian-filtered versi
the data, distributed proportional to its occurrence within the defined bounding box.

Histogram

Raw Data

Figure 4.4a (bottom graph) displays a histogram from raw depth data. Data points A and B ar
two most dominant features, and therefore would be compared in Depth analysis. Depending
the range and size of depth data, the curve may appear jagged in profile, with noticeable lev
noise.

Note: Color of cursor, data, and grid may change if user has changed the setting
Right-click on the graph and go to Color if you want to change the default 
settings. 
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Figure 4.4a   Depth Histogram

Correlation Curve

The Correlation  Curve is a filtered version of the Raw Data Histogram and is located on the 
Raw Data Histogram represented by a red line. Filtering is done using the Histogram filter  cutoff 
parameter in the Input parameters box.The larger the filter cutoff, the more data is filtered into
Gaussian (bell-shaped) curve. Large filter cutoffs average so much of the data curve that pea
corresponding to specific features are unrecognizable. On the other hand, if the filter cutoff is
small, the filtered curve may appear noisy.

The Correlation Curve portion of the histogram presents a lowpass, Gaussian-filtered version
the raw data. The low-pass Gaussian filter removes noise from the data curve and averages
curve’s profile. Peaks which are visible in the curve correspond to features in the image at dif
depths.

Peaks do not show on the correlation curve as discrete, isolated spikes; instead, peaks are 
contiguous with lower and higher regions of the sample, and with other peaks. This reflects t
reality that features do not all start and end at discrete depths. 

When using the Depth View for analysis, each peak on the filtered histogram is measured from
statistical centroid (i.e., its statistical center of mass). 

Using the Grid Display

Measurement cursors for histogram are automatically positioned based on the numerical val
selected in the Input  fields. Right-clicking on the grid will bring up the Grid Parameters menu 
(see Figure 4.4b) and allow you to make the following changes:

30 60 90 1200
Depth (nm)

3

2

1

A
B

A

B
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Figure 4.4b   Grid Parameters Menu

Color Allows operator to change the color of the:

• Curve (data)

• Text

• Background

• Grid

• Minor Grid

• Markers

Filter Typically used for a Profiler Scan.

• Type—Select None, Mean (default), Maximum, or Minimum

• Points—Select 4k, 8k (default), 16k, or 32k

Minor Grid Places a minor grid in the background of the Vision window.

Scale Allows user to auto scale, set a curve mean, or set their own data 
range

Line Style For each curve, the operator can choose a connect, fill down, or point 
line.

User Preferences Restore—Reverts to initial software settings

Save—Saves all changes operator has made during this session. This 
becomes the new default settings.

Copy Clipboard Copies the grid image to the Microsoft Clipboard

Print Prints out the current screen view to a printer

Export Exports data in bitmap, JPEG or XZ data format

Active Curve Determines which curve you are analyzing
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4.4.2 Depth Procedures

1. If no workspace is present, open a new workspace (File > New Workspace).

2. Open the image you wish to analyze (File > Open > Captured Data File) or double click on 
the browse view image. 

3. In the workspace, position the cursor on the file name and right-click to access a funct
pop-up menu.

Figure 4.4c   Functions Menu

4. In the pop-up menu, select Add View > Depth.

5. You can view the Depth View using one of the following methods:

• Right-click on the image name in the Workspace and select Add View > Depth from 
the popup menu.

                                     Or

• Select Analyze > Depth from the menu bar.

                                     Or

• Click the Depth icon in the upper toolbar. 

6. Using the mouse, left-click and drag a box on the area of the image to analyze. 
The Histogram displays the depth correlation on this specified area.

Note: If no box is drawn, by default, the entire image is selected.

7. Adjust the Minimum Peak to Peak to exclude non relevant depths.

8. Adjust the Histogram Filter Cutoff  parameter to filter noise in the histogram as desired.
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9. Note the results.

Note: To save or print the data, run the analysis in an Auto Program 
(see Section 4.11).

Figure 4.4d   Depth Interface

4.4.3 Depth Interface

The Depth interface includes a captured image, Input  parameters, Results parameters and a 
correlation histogram (see Figure 4.4e).

Figure 4.4e   Depth Histogram
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Depth Input Parameters

The depth input parameters below define the slider cursor placement for determining the exa
depth of a feature.

Results Parameters:

Number of Histogram Bins The number of data points, ranging from 4 to 512, which result from th
tering calculation.

Histogram Filter Cutoff Lowpass filter which smooths out the data by removing wavelength co
nents below the cutoff. Use to reduce noise in the Correlation histogra

Min Peak To Peak Sets the minimum distance between the maximum peak and the seco
peak marked by a cursor. The second peak is the next largest peak to
this distance criteria.

Left Peak Cutoff The left (smaller in depth value) of the two peaks chosen by the curso
Value used to define how much of the left peak is included when calcul
the centroid. At 0 percent, only the maximum point on the curve is 
included. At 25 percent, only the maximum 25 percent of the peak is 
included in the calculation of the centroid. 

Right Peak Cutoff The right (larger in depth value) of the two peaks marked by the curso
Value used to define how much of the right peak is included when calc
ing the centroid. At 0 percent, only the maximum point on the curve is
included. At 25 percent, only the maximum 25 percent of the peak is 
included in the calculation of the centroid.

Peak to Peak Distance Depth between the two data peak centroids as selected using the line
sors.

Minimum Peak Depth The depth at which the smaller of the two peaks occurs.

Maximum Peak Depth The depth at which the larger of the two peaks occurs.

Depth at Histogram Max Depth at the maximum peak on the histogram.

Number of Peaks Found Total number of peaks included within the data histogram.
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4.5 Power Spectral Density

The Power Spectral Density (PSD) function is useful in analyzing surface roughness. This 
function provides a representation of the amplitude of a surface’s roughness as a function of
spatial frequency of the roughness. Spatial frequency is the inverse of the wavelength of the
roughness features. 

The PSD function reveals periodic surface features that might otherwise appear “random” an
provides a graphic representation of how such features are distributed. On turned surfaces, 
helpful in determining speed and feed data, sources of noise, etc. On ground surfaces, this m
reveal some inherent characteristic of the material itself such as grain or fibrousness. At high
magnifications, PSD is also useful for determining atomic periodicity or lattice.

Refer to the following Power Spectral Density sections:

• NanoScope PSD Measurements:  Section 4.5.1

• PSD and Surface Features:  Section 4.5.2

• PSD and Flatness:  Section 4.5.3

• Performing a Spectral Density Analysis:  Section 4.5.4

• Changing Parameters of the Spectrum Plot:  Section 4.5.5

4.5.1 NanoScope PSD Measurements

The Power Spectral Density function computes the following information for the image:

• Total power spectrum—Power is roughness amplitude squared, so power is in units
length squared for a topographic image. Power spectrum is a plot of power as a fun
of spatial wavelength or frequency.

• 1D PSD—A one dimensional power spectral density. Power spectral density is a plo
the density, in spatial frequency space, of the power spectrum. Its units are length
squared divided by a one dimensional frequency, or 1 over length, which is length 
cubed. A 1D PSD can be calculated in either the X direction of the data or in the Y
direction.

• 1D isotropic PSD—A different version of a one dimensional power spectrum.

• 2D isotropic PSD—A two dimensional power spectral density. Its units are length 
squared divided by a two dimensional frequency, or 1 over length squared, which i
length to the fourth power. This is isotropic in the sense that it is an average taken
all directions in the data.

• RMS roughness values—Since the RMS roughness is the square root of the integra
the PSD, over some wavelength or frequency interval, this calculation can be 
conveniently done when one has the PSD.
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4.5.2 PSD and Surface Features

Consider the image in Figure 4.5a.

Figure 4.5a   Waveform Surfaces

This synthetic surface consists of essentially two dominant wave forms: a long period wavefo
along the X-axis, and a shorter period waveform along the Y-axis. A 2 dimensional power spe
density plot consists of two dominant spikes (one for each dominant wavelength), plus some
number of extra wavelengths inherent within the image. (These extra wavelengths may appe
to fine surface features and/or side bands of the dominant wave forms.) Because of the sinu
nature of the composite wave form, a relatively small set of spectral frequencies suffices to de
the entire surface. By contrast, an image comprised of angular (saw-toothed or square) wave
contains more spatial frequency components.

Over a given range of spatial frequencies the total power of the surface equals the RMS roug
of the sample squared. 

The frequency distribution for a digitized profile of length L, consisting of N points sampled a
intervals of do is approximated by:

Where i = √-1, and frequencies, f, range from  to . Practically speaking, the algorithm us

to obtain the PSD depends upon squaring the FFT of the image to derive the power. Once th
power, P, is obtained, it may be used to derive various PSD-like values as follows:

2D Spectrum 

X
Y
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The terms used in the denominators above are derived by progressively sampling data from 
image’s two-dimensional FFT center (see Figure 4.5b).

Figure 4.5b   Progressive Data Sampling

Each sampling swings a “data bucket” of given frequency f. Since samples are taken from the 

image center, the sampling frequency, f, is limited to , where N is the scan size in pixels. This

forms the upper bandwidth limit (i.e., the highest frequency or Nyquist frequency) of the PSD
The lower bandwidth limit is defined at 1/L.

4.5.3 PSD and Flatness

PSD is used increasingly as a metrology tool for evaluating extremely flat surfaces, such as 
polished or epitaxial silicon. Generally, the desired surface is expected to adhere to certain PSD 
thresholds, signifying it meets a specified flatness criterion. 

The main advantage gained over traditional RMS specifications is that PSD flatness is qualified 
through the full spectral range of interest. For example, one may specify spectral thresholds 
frequencies measured on the atomic scale, thus ensuring surfaces consist largely of uniform
lattices. Setting the precise thresholds for various materials remains a matter of debate.

Consider the image of epitaxial gallium arsenide in Figure 4.5c.

Figure 4.5c   Epitaxial Gallium Arsenide Image

f = 1 pixel f = 2 pixels f = 3 pixels f = 4 pixels

∆f

N 2⁄
L

-----------
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This surface is comprised of “terraces” formed from the material’s natural lattice structure; ea
terrace is one atomic monolayer thick and is spaced at fairly regular intervals. This degree of
flatness is handily evaluated with PSD, as the terraces produces a spectral spike correspond
their spacing wavelength. A PSD plot for this type of surface generally takes the form shown
Figure 4.5d.

Figure 4.5d   PSD Plot for Terraced Sample

This tapered PSD plot is characteristic of flat, isotropic surfaces. Longer wavelengths are pre
up to the scan width, and are accompanied by uniformly decreasing powers of shorter wavel
down to 2 pixels. On the plot shown above a spike stands out, corresponding to the wavelen
spacing of the terraced features. Depending upon the qualitative standards of the person eva
such a plot, this spike may exceed a threshold standard of flatness.

4.5.4 Performing a Spectral Density Analysis

To use the PSD Analysis function, perform the following procedures:

1. Select View > Browse from the menu bar, then open the image you wish to analyze by 
double-clicking it. 

2. You can view the PSD Analysis View using one of the following methods:

• Right-click on the image name in the Workspace and select Add View > PSD from the 
popup menu.

                                     Or

• Select Analyze > PSD from the menu bar.

                                     Or

• Click the PSD icon in the upper toolbar. 

 

Special spike corresponding to “terrace” spacings on surface

104

10-1

101 10-2

3D Isotropic PSD

P
S
D

Wavelength (mm/cycle)
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The PSD window opens to allow spectral density plotting on the Display Monitor (see Figure 4.5e). 

Figure 4.5e   PSD Analysis

Compute PSD Buttons

Once the PSD analysis window is opened, select the type of spectral density analysis you wish
perform by clicking the appropriate button above the Results window.

2D Isotropic—Executes a two-dimensional Power Spectral Density analysis.

Horizontal Axis—Executes a one-dimensional Power Spectral Density analysis along the X-axis.

Vertical Axis—Executes a one-dimensional Power Spectral Density analysis along the Y-axis.

The calculation begins as soon as the button is selected. The PSD and a table of values from the 
graph are shown in the Results window. Completion of the analysis will also result in a 
topographical histogram in the spectrum plot window (see Figure 4.5f).
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Figure 4.5f   Power Spectral Density Histogram

Results Display

The Results window displays the Name and Value of the procedures performed during a PSD 
analysis. The teal shaded area in the display window corresponds to the area designated by
cursor on the Power Spectral Density histogram, and the purple shaded area corresponds to th
purple cursor. The operator can select to have a report generated for each Result displayed by 
toggling the Report window between Yes and No. Right-clicking in the Results window will open 
a popup menu (see Figure 4.5g) that allows you to set the result properties, select the paramete
that will be displayed, and export the results data to the clipboard as a text file.

Figure 4.5g   Power Spectral Density Display
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Set Properties

The operator can select the wavelength properties for each Results window parameter by selecting
Set Properties from the Results popup menu, which opens the Result Properties window (see 
Figure 4.5h), and entering the a Minimum Value  and a Maximum Value. Checking the Report 
Value check box will change the Report window from No to Yes for that particular parameter. 
When PSD is being used as part of an AutoProgram (see AutoProgram:  Section 4.12), Checking 
the Check Limits box will cause the analysis to fail if the results are not within designated lim

Figure 4.5h   Result Properties Window

Select Displayed Parameters

The operator can select which Results will or will not be displayed in the Results window by 
Right-clicking in the Results window, selecting Toggle Show All from the popup menu, and 
checking or unchecking the appropriate boxes (see Figure 4.5i).

Figure 4.5i   Select Show All On/Off Check Boxes
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Export Text

Selecting Export Text from the popup menu will copy the text from the Results window, in tab-
delimited text format, to the Windows clipboard. You may then paste it into a text or word 
processing program.

4.5.5 Changing Parameters of the Spectrum Plot

The Spectrum Plot window displays results of the PSD analysis (see Figure 4.5j). The window has 
two cursors whose color corresponds to the shaded areas in the Results window. You can move 
either of these cursors within the Spectrum Plot window by placing the cross hair cursor directly
over the cursor, clicking and holding the left mouse button, and dragging the mouse to the lef
right. You can also move both cursors simultaneously by left-clicking the mouse with the cros
cursor anywhere between the two cursors and dragging to the left or right.

To change the parameters of the Spectrum Plot, right-click in the Spectrum Plot window at the 
bottom of the display and choose from the popup menu.

Figure 4.5j   Spectrum Plot Parameter Menu

Popup MenuTeal Cursor Purple Cursor Spectrum Plot
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Spectrum Plot Popup Menu Items

Color—Changes the colors of the curves, text, background, grid lines, minor grid lines (if 
selected), and the marker pairs (see Figure 4.5k).

Filter —Selects Filter type and points (see Figure 4.5l).

Minor Grid —Shows/hides minor grid lines

Figure 4.5k   Color Menu Items

Figure 4.5l   Filter Menu Items

Scale—Sets the vertical axis range, the center of the range, or allow the software to autoscal
Figure 4.5m).

Line Style—Changes the line style of the Spectrum Plot graphical display (see Figure 4.5n).

User Preferences—You can either save all changes made to the graphical display, or restore 
previously saved settings (see Figure 4.5o). Save will result in all graphical displays maintaining 
any design changes made to this display.
2 Nanoscope Software 6.13 User Guide Rev. D
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Copy Clipboard—Copies the graphical display only to the Windows clipboard, allowing it to b
pasted into any compatible Windows program.

Print —Prints the graphical display only to a printer.

Export—Saves the graphical display as a JPEG graphic, a Bitmap graphic, or as an XZ Data
text, which can be read in a database program (i.e. Excel).

Active Curve—Changes the curve displayed when more than one curve has been plotted. (D
not occur in PSD).

Figure 4.5m   Scale Settings Dialog Box

Figure 4.5n   Line Style Display
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Figure 4.5o   User Preferences Menu

4.6 Roughness

The Roughness command generates a variety of statistics on surfaces, including classical 
roughness values, and peak and zero crossing data. “Image” statistics are reported for the e
image. “Box” statistics are reported only for the region you define within a cursor box. In addi
the data can be augmented with stopbands, (excluding features) to isolate desired analysis.

Refer to the following sections on Roughness:

• Roughness Theory:  Section 4.6.1

• Roughness Procedures: Section 4.6.2

• Roughness Interface: Section 4.6.3

Most industrial standards for roughness measurement call for planefitting data before calculating 
values. Planefitting applies a temporary, first-order planefit before calculating statistics. On m
surfaces, especially those which are tilted, this yields different values from those seen in raw
(unplanefitted) data. Moreover, peripheral features included within the analyzed region may 
produce cumulative results uncharacteristic of the feature(s) of interest. To ensure the best r
you should observe the following rules when using Roughness analysis:

• If the image shows signs of second- or third-order distortion (e.g., bow due to large
scans on large scanners), apply a second- or third-order Flatten and Planefit to the 
image before using Roughness analysis.

• Isolate your analysis to specific areas of the image. This may be accomplished by 
the box cursor in Roughness to analyze only select portions of the image.
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4.6.1 Roughness Theory

Regarding the effects of Planefitting on Roughness statistics—When Roughness analysis is 
applied to an image, statistical values are calculated according to the relative heights of each
in the image. Planefitting (used to correct images for tilt and bow) reorients these pixels in a 
manner which can affect roughness statistics dramatically on some surfaces. This is especia
of surfaces having broad, coplanar features. Planefitting can be applied at the time of file cap
using Offline planefit from a Channel panel, or via the Analyze > Plane Fit function.

When Roughness analysis is applied to an image, the image data is automatically planefit 
beforehand. This is done to accord with ASME and ISO metrological standards. (Only the Raw 
mean parameter is exempt from this operation, being calculated from raw data only.) To avoid
unexpected results due to planefitting, be certain to apply Roughness analysis only to the surface(s)
of interest by utilizing a cursor box, or by scanning just the specific site of interest. Including 
peripheral features within an analyzed area may produce cumulative results uncharacteristic
feature(s) of interest.

The relationship between the zero plane and the data also changes according to the setting 
Offline planefit parameter. If the Offline planefit parameter is set to None the offset is not 
removed from the data and it is very possible that the zero plane does not intersect the data.
other settings of the parameter subtract the average Z value from every point in the image so
data varies around the zero plane.

Regarding Basic Roughness Measurements—Average roughness (Ra) is one of the most commonly
used roughness statistics. Figure 4.6a represents two surfaces having the same average roughn

Similarly, a number of other roughness values are based upon least-squares calculations (e.g
roughness, or Rq), and their algorithms are more concerned with a best fit of all height points t
with the spatial frequency of features.

The surface of image A is represented as having a high frequency profile of features. Image B 
represents a separate surface having the same average feature height, but distributed at wid
(lower-frequency) intervals. In terms of average and RMS roughness, both surfaces are equa
rough. If you are interested in differentiating between the two, you must rely upon other statis
parameters such as Power Spectral Density.

Figure 4.6a   Basic Roughness Measurements

A B

Best-fit plane 
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4.6.2 Roughness Procedures

Example of Using Roughness Analysis

For general Roughness Analysis, complete the following procedures:

1. Select an image file from the file browsing window at the right of the main window. Dou
click the thumbnail image to select and open the image.

2. You can view the Roughness View using one of the following methods:

• Right-click on the image name in the Workspace and select Add View > Roughness 
from the popup menu.

                                     Or

• Select Analyze > Roughness from the menu bar.

                                     Or

• Click the Roughness icon in the upper toolbar. 

3. The Roughness View appears showing results for the entire image.

4. To perform Roughness measurements within an area, left-click and move the mouse to d
a measurement box. Click on the Execute button to calculate the Roughness inside the box.

5. To exclude an area, right-click in the image to access a pop-up menu and select Stop band. 
Using the mouse, draw a box around the area to be excluded by the stop band comma
Click on the Execute button to calculate the Roughness outside the box.
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4.6.3 Roughness Interface

The Roughness View shows the image along with Input  parameters and a Results window.

Note: Some parameters are reported only when certain subroutines are turned o

Figure 4.6b   Roughness Display

Results 
Parameters

Input
Parameters
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Input Parameters

Peak

The Peak feature, when switched On, isolates specified height portions of the image (peaks) fro
background data. Peaks are specified using the Peak Threshold parameters, either in terms of their
absolute height or their deviation from the RMS value of all surface data, and relative to eithe
highest data point (Peak) or the mean (Zero). When Peak is turned On, portions of the image 
contained within the box cursor and falling within the specified boundaries are retained; all o
data is removed.

Range or Settings—When Peak is turned On, the following subcommands are activated (see 
Figure 4.6c): 

When Peak is turned On, the following statistical parameters are turned on. All Peak parameters 
are calculated from the thresholds you define with the Peak subcommands.

• Rz

• Rz count

• Max peak ht (Rp)

• Av. Max ht (Rpm)

• Max depth (Rv)

• Av. max depth (Rvm)

When Peak is turned Off , statistics are not calculated.

Peak Threshold 
Reference

The Reference buttons select whether the threshold is defined relative to 
the Zero (lowest) value, or the tallest Peak in the selected region.

Peak Threshold 
Value Type

The Value Type determines whether the threshold is defined as an abso-
lute distance from the reference point in nanometers (Absolute value) or 
a percentage of the root-mean-square (Rms %) of the Z values.

Peak Threshold 
Value 

The Value is an absolute distance from the reference point in nanometers 
(Absolute value) or a percentage of the root-mean-square (Rms %) of the 
Z values.
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Figure 4.6c   Input On Parameters

Zero Crossing

A zero crossing is a point where the Z values go through zero regardless of slope. This value
total number of zero crossings along both the X and Y center lines divided by the sum of the
dimensions.

Range or Settings—When Zero crossing is turned On and you click the Execute button, the 
number of zero crossings along the X and Y center lines of the box cursor is determined (seeFigure 
4.6c). The number of zero crossings is divided by the sum of the lengths of the X and Y cente
and reported as the Line density.

When Zero crossing is turned Off , the zero crossing determination is not performed.

Peak Input Parameter ON

Zero Crossing 
Input Parameter ON
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Results Parameters

Statistics used by the Roughness routine are defined in this section. The terms are listed 
alphabetically. Most are derived from ASME B46.12 (“Surface Texture: Surface Roughness, 
Waviness and Lay”) available from the American Society of Mechanical Engineers, which sho
be consulted.

Rz This is the average difference in height between the five highest peaks and
five lowest valleys relative to the Mean Plane. In cases where five pairs of 
peaks and valleys do not exist, this value is based on fewer points.

Av max Depth (Rvm) Average distance between the five lowest profile points and the mean data
plane.

Av max ht (Rpm) Average distance between the five highest profile points and the mean data
plane.

Box x Dimension The width of the Lx box cursor you define.

Box y Dimension The length of the Ly box cursor you define.

Image Mean Mean value of data contained within the image.

Image Projected surface 
area

Area of the image rectangle (X x Y).

Image Ra Arithmetic average of the absolute values of the surface height deviations 
measured from the mean plane. 

Image Raw mean Mean value of image data without application of plane fitting.

Image Rmax Maximum vertical distance between the highest and lowest data points in 
the image following the planefit.

Image Rq Root mean square average of height deviations taken from the mean 
image data plane, expressed as:

Image Surface area The three-dimensional area of the entire image. This value is the sum of 
the area of all of the triangles formed by three adjacent data points.

Image Surface Area 
Difference

Difference between the image’s three-dimensional Surface area and two-
dimensional projected surface area.

Image Z range Maximum vertical distance between the highest and lowest data points in 
the image prior to the planefit.

Ra
1
N
---- Zj

j 1=

N

∑=

Zi
2∑

N
---------------
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Kurtosis This is a non-dimensional quantity used to evaluate the shape of data 
about a central mean. It is calculated as

Graphically, kurtosis indicates whether data are arranged flatly or sharply 
about the mean.

Line Density The number of zero crossings per unit length on the X and Y center lines 
of the box cursor. A zero crossing is a point where the Z values go through 
zero regardless of slope. This value is the total number of zero crossings 
along both the X and Y center lines divided by the sum of the box dimen-
sions.

Max Depth (Rv) Lowest data point in examined region.

Max Height (Rmax) Maximum vertical distance between the highest and lowest data points 
within the cursor box.

Max Peak ht (Rp) Maximum peak height within the analyzed area with respect to the mean 
data plane.

Mean The average of all the Z values within the enclosed area. The mean can 
have a negative value because the Z values are measured relative to the Z
value when the microscope is engaged. This value is not corrected for tilt 
in the plane of the data; therefore, plane fitting or flattening the data 
changes this value.

Mean Roughness (Ra) Arithmetic average of the absolute values of the surface height deviations 
measured from the mean plane within the box cursor:

Projected Surface Area Area of the selected data.

Raw Mean Mean value of image data within the cursor box you define without appli-
cation of plane fitting.

Rms (Rq) This is the standard deviation of the Z values within the box cursor and is 
calculated as:

where Zi is the current Z value, and N is the number of points within the 

box cursor. This value is not corrected for tilt in the plane of the data; 
therefore, plane fitting or flattening the data changes this value.

Rz Count Number of Surface peaks taller than the threshold.

Kurtosis
1

Rq
4
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N
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Rev. D Nanoscope Software 6.13 User Guide 141



Analysis Commands
Section

14

rence 
g the 

ed for 
4.7 Section

The Section command displays a top view image, upon which a single reference line may be 
drawn. The cross-sectional profiles and fast Fourier transform (FFT) of the data along the refe
line is shown in separate windows. Roughness measurements are made of the surface alon
reference line you define.

Section is probably the most commonly used Analyze command; it is also one of the easiest 
commands to use. To obtain consistently accurate results, ensure your image data is correct
tilt, noise, etc. before analyzing with Section.

• Sectioning of Surfaces: Overview: Section 4.7.1

• Section Procedures: Section 4.7.2

• Section Interface: Section 4.7.3

Skewness Measures the symmetry of surface data about a mean data profile, 
expressed as:

where Rq is the Rms roughness. Skewness is a non dimensional quantity 

which is typically evaluated in terms of positive or negative. Where Skew-
ness is zero, an even distribution of data around the mean data plane is 
suggested. Where Skewness is strongly non-zero, an asymmetric, one-
tailed distribution is suggested, such as a flat plane having a small, sharp 
spike (> 0), or a small, deep pit (< 0).

Surface Area The three-dimensional area of the region enclosed by the cursor box. This 
value is the sum of the area of all of the triangles formed by three adjacent 
data points.

Surface Area Diff Difference between the analyzed region’s three-dimensional Surface area 
and its two-dimensional, footprint area.

Z Range Peak-to-valley difference in height values within the analyzed region.

Skewness
1

Rq
3
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N
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N
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4.7.1 Sectioning of Surfaces: Overview

Samples are sectioned to learn about their surface profiles. The Section command does not reveal 
what is below the surface—only the profile of the surface itself. When sectioning samples, you 
should first ascertain surface topology. Depending upon the topology and orientation of the sa
the results of Section analysis may vary tremendously.

Figure 4.7a   Section Analysis Orientation

In Figure 4.7a, the sample surface (a diffraction grating) is sectioned along three axes. Sectio
and 2 are made perpendicular to the grating’s rules, revealing their blaze and spacings. (Sec
and 2 may be compared simultaneously using two fixed cursor lines, or checked individually w
moving cursor.) Section 3 is made parallel to the rules, and reveals a much flatter profile beca
its orientation.

The Section command produces a profile of the surface, then presents it in the Section grid (see 
Figure 4.7b).

1

2       

3

3

2

1
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Figure 4.7b   Section Command Profile

Generally, Section analysis proves most useful for making direct depth measurements of surfa
features. By selecting the type of cursor (fixed, moving, or average), and its orientation to fea
you may obtain:

• Vertical distance (depth), horizontal distance and angle between two or more poin

• Roughness along section line: RMS, Ra, Rmax, Rz.

• FFT spectrum along section line.

Features are discussed below. Refer to Roughness: Section 4.6 for additional information 
regarding roughness calculations.

Using the Grid Display

Measurement cursors for histogram and cross section views in depth and section are provide
left and right of the Grid Display. You can bring the cursors into the grid by placing the mouse 
cursor onto the measurement cursors, clicking and holding the left mouse button, and dragg
them onto the grid. When you place the mouse cursor onto a measurement cursor, the curso
change to a horizontal or vertical double-arrow cursor , which indicates you can grab and
this cursor.

Right-clicking on the grid will bring up the Grid Parameters menu (see Figure 4.4b) and allow 
you to make the following changes:

Color Allows operator to change the color of the

• Curve (data)

• Text

• Background

• Grid

• Minor

• Marker
4 Nanoscope Software 6.13 User Guide Rev. D
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Figure 4.7c   Grid Parameters Menu

Filter Typically used for a Profiler Scan.

• Type—Select None, Mean (default), Maximum, or Minimum

• Points—Select 4k, 8k (default), 16k, or 32k

Minor Grid Places a minor grid in the background of the Vision Window.

Scale Allows user to auto scale, set a curve mean, or set their own data 
range

Line Style For each curve, the operator can choose a connect, fill down, or point 
line.

User Preferences Restore—Reverts to initial software settings

Save—Saves all changes operator has made during this session. This 
becomes the new default settings.

Copy Clipboard Copies the grid image to the Microsoft Clipboard

Print Prints out the current screen view to a printer

Export Exports data in bitmap, JPEG or XZ data format

Active Curve Determines which curve you are analyzing
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4.7.2 Section Procedures

1. Select an image file from the file browsing window at the right of the main window. Dou
click the thumbnail image to select and open the image.

2. You can view the Section View using one of the following methods:

• Right-click on the image name in the Workspace and select Add View > Section from 
the popup menu.

                                     Or

• Select Analyze > Section from the menu bar.

                                     Or

• Click the Section icon in the upper toolbar. 

3. Before doing a section analysis, ensure that the image is properly oriented by removin
tilt or bow. This is especially important if a high level of precision is to be employed in 
measuring the blaze angle.

4. To remove any tilt which might be present, select Analyze > Plane Fit. Set the Planefit 
Order  parameter in the panel to 1st, then click the Execute button. The image is fitted to a 
plane (“leveled”) by fitting each scan line to a first-order equation, then fitting each scan
to others in the image. At this point, the image has not been appreciably altered, it has
been reoriented slightly.

5. In Section Analysis, to make a single-line section of the image, use the mouse to draw
through the image, as in Figure 4.7d, and note the results.

6. Move the grid cursors along the section to make measurements.

Figure 4.7d   Mouse Drawing Line

Use the mouse to drag a line
cursor across the image.
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4.7.3 Section Interface

When a line is drawn on the image, the cross-sectional profile is displayed in the upper right 
window, and the FFT spectrum along the line is displayed directly below it (see Figure 4.7e). More 
detail about the FFT algorithm used may be found at http://www.fftw.org.

The markers may be positioned in the profile and FFT spectrum. The results window at the b
of the display lists roughness information based on the position of the presently selected refe
markers. Each marker pair is color coordinated with the data in the results window.

Figure 4.7e   Section View

Grid Markers:

A pair of markers in the section grid and a single marker in the spectrum grid will automatical
drawn. Place the mouse cursor on the desired marker and left-click to move.

Marker pair 0 Default display color is blue. Slide the markers into the grid from the left or right side by 
clicking and holding the left mouse button. Data between the two markers will be dis-
played in the results window at the bottom of the display screen in blue.

Marker pair 1 Default display color is red. Slide the markers into the grid from the left or right side by 
clicking and holding the left mouse button. Data between the two markers will be dis-
played in the results window at the bottom of the display screen in red.
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Results Parameters:

The standard deviation RMS (Rq), mean roughness (Ra), the maximum height (Rmax), and the 

10-point roughness (Rz) for the segment between the reference markers are also listed in the 

Results parameter grid. 

Results Parameters:

Changing the cursor on the FFT changes lc, the cutoff length of the high-pass filter applied to the

data. The filter is applied before the roughness data is calculated; therefore, the position of t
cutoff affects the calculated roughness values.

• RZ Count—number of peaks used for rz computation

Marker pair 2 Default display color is green. Slide the markers into the grid from the left or right side 
by clicking and holding the left mouse button. Data between the two markers will be 
displayed in the results window at the bottom of the display screen in green.

Spectrum Marker Displays the third slider cursor location along the spectral data (e.g., FFT Spectrum).

Length Length of the roughness curve.

RMS (Standard Devia-
tion)

Standard deviation of the Z values between the reference markers, calcu-
lated as:

where Zi is the current Z value, Zave is the average of the Z values 

between the reference markers, and N is the number of points between the 
reference markers.

 Ra (Mean Roughness) Mean value of the roughness curve relative to the center line, calculated 
as:

where L is the length of the roughness curve and f(x) is the roughness 
curve relative to the center line.

Rmax (Maximum Height) Difference in height between the highest and lowest points on the cross-
sectional profile relative to the center line (not the roughness curve) over 
the length of the profile, L.

Rz (Ten-Point Mean 
Roughness)

Average difference in height between the five highest peaks and five low-
est valleys relative to the center line over the length of the profile, L. In 
cases where five pairs of peaks and valleys do not exist, this is based on 
fewer points.

Freq. Cutoff (υυυυm) Frequency Cutoff measured in terms of a percentage of the root mean 
square.

RMS σ
Zi Zave–( )∑ 2

N
-------------------------------------= =
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• Radius—radius of circle fitted to the data between the cursors

• Radius Sigma—mean square error of radius calculation

• Surface Distance—distance measured along the surface between the cursors

• Horizontal Distance—horizontal distance between the cursors

• Vertical Distance—vertical distance between the cursors

• Angle—angle of the imaginary line drawn from the first cursor intercept to the seco
cursor intercept

• Spectral Period—spectral period at the cursor position

• Spectral Frequency—spectral frequency at the cursor position

• Spectral RMS Ampl.—amplitude at the cursor position

Mouse Operations for a Line Cursor:

• Mouse down, drag—Anchors the origin of a line segment and expands from the selec
position, allowing a line segment to be drawn in any direction.

• Mouse up—Anchors the terminal point of the first (dashed) line segment and draws
moving reference line perpendicular to the fixed-line segment. The cross-sectiona
profile and the FFT along the reference line are displayed at this time. The position
the moving reference line tracks the movements of the mouse. When the mouse is
stationary, the cross-sectional profile and the FFT of the data along the moving refe
line is updated on the Display Monitor.

• Clicking on the center of the line and dragging moves the line on the image.

• Clicking on either end of the line rotates the line.
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Mouse Operations for Box Cursor (Right-Click Selection):

• 1st click—Anchors the origin of a box and “rubber bands” out from the center of the
selected position.

• As a reference, the cursor positions show up on the center line in the box.

• Clicking on the box—Allows the box to be moved (cursor inside box), or resized (curs
on edge of box). Clicking on the corner allows the box to be resized in two directio

• Holding the Shift button down while clicking on the box and dragging in a circular 
direction rotates the box.

4.8 Step

The Step command makes relative height measurements between two regions (steps) on sam
surfaces. Typical applications include measuring film thickness and etch depths. Step works 
similarly to a Section command with an averaging box cursor, but its operation is simplified.

Step displays a top view of the image, then a reference line is drawn across the regions to be
measured. A height profile is generated from averaged data on either side of the reference li
Cursors—which are moved along the profile—define specific regions (steps). These may be 
measured (Measure button) relative to each other, with or without data leveling (Level button).

4.8.1 Step Interface

The Step interface, shown in Figure 4.8a, includes a captured image and a graph of averaged he
within a selected box. Two pairs of cursors (one black and one red) can be moved across this
to define the steps to be measured. The region between each cursor defines a “step.” The m
position is shown below the height graph.
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Figure 4.8a   Step Interface

Stepheight Display Menu Commands

Level

Reorients the profile so that the average height of each step region (between cursor pairs) is

Figure 4.8b   Level Option Profile
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Measure

Displays the relative height between steps.

Restore

Returns the profile to its original, unleveled form. (Deselects the Level option.)

Results

vertDist

Displays the difference between the average height of each region (between cursor pairs).

Mouse Operation (within image)

• 1st click—Anchors the origin of a line segment and “rubberbands” from the selecte
position, allowing the line segment to be drawn in any direction.

• 2nd click—Anchors the terminal point of the first line segment and draws a box alon
the fixed-line segment. The average profile of the lines perpendicular to the segmen
confined by the box is displayed.

• As a reference, the cursor positions also show up as red and green lines in the bo

• 3rd click—Allows the box to be moved (cursor inside box), or resized (cursor on edg
box). Clicking on the corner allows the box to be resized in two directions.

• 4th click—Fixes the box position or size.

Using the Grid Display

Measurement cursors for histogram are automatically positioned based on the numerical val
selected in the Input  fields. Right-clicking on the grid will bring up the Grid Parameters menu 
(see Figure 4.9b) and allow you to make the following changes:

Color Allows operator to change the color of the:

• Curve (data)

• Text

• Background

• Grid

• Minor Grid

• Markers
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Figure 4.8c   Grid Parameters Menu

4.9 Width

To analyze the width of features you have numerous choices which measure the height diffe
between two dominant features that occur at distinct heights. Width  was primarily designed for 
automatically comparing feature widths at two similar sample sites (e.g., when analyzing etch 
depths on large numbers of identical silicon wafers).

The Width  command is designed to automatically measure width between features distinguis
by height, such as trenches and raised features. 
This algorithm utilizes many of the same functions found in Depth analysis by accumulating height
data within a specified area, applying a Gaussian low-pass filter to the data (to remove noise

Filter Typically used for a Profiler Scan.

• Type—Select None, Mean (default), Maximum, or Minimum

• Points—Select 4k, 8k (default), 16k, or 32k

Minor Grid Places a minor grid in the background of the Vision window.

Scale Allows user to auto scale, set a curve mean, or set their own data 
range

Line Style For each curve, the operator can choose a connect, fill down, or point 
line.

User Preferences Restore—Reverts to initial software settings

Save—Saves all changes operator has made during this session. This 
becomes the new default settings.

Copy Clipboard Copies the grid image to the Microsoft Clipboard

Print Prints out the current screen view to a printer

Export Exports data in bitmap, JPEG or XZ data format

Active Curve Determines which curve you are analyzing
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rapidly obtaining height comparisons between two dominant features. For example, 1) the de
a single feature and its surroundings; or, 2) depth differences between two or more dominan
features. Although this method of width measurement does not substitute for direct, cross-
sectioning of the sample, it does afford a means for comparing feature widths between two o
similar sites in a consistent, statistical manner. 
The Width  command is best applied when comparing similar features on similar sites. Width 
measurement on dissimilar sites is better performed using the Section command.

Refer to the following sections on Width  analysis:

• Width Theory: Section 4.9.1

• Width Procedures: Section 4.9.2

• Width Interface: Section 4.9.3

4.9.1 Width Theory

The Width  command accumulates width data within a specified area, applies a Gaussian low
filter to the data to remove noise, then obtains width comparisons between two dominant fea
Although this method of width analysis does not substitute for direct, cross-sectioning of the 
sample, it affords a means for comparing feature width between two similar sites in a consist
statistical manner.

The display screen includes a top view image and a histogram; depth data is displayed in the
window and in the histogram. The mouse is used to resize and position the box cursor over th
to be analyzed. The histogram displays both the raw and an overlaid, Gaussian-filtered versi
the data, distributed proportional to its occurrence within the defined bounding box.

Histogram

Raw Data

Histograms for depth data are presented on the bottom of the Width  window. The histogram peaks
correspond to the different parts of the image (see Figure 4.9a).
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Figure 4.9a    Width Histogram Analysis

Note: Color of cursor, data, and grid may change if user has changed the setting
Right-click on the graph and go to Color if you want to change the default 
settings. 

Correlation Curve

The Correlation  Curve is a filtered version of the Raw Data Histogram and is located on the 
Raw Data Histogram represented by a red line. Filtering is done using the Histogram filter  cutoff 
parameter in the Input parameters box.The larger the filter cutoff, the more data is filtered into
Gaussian (bell-shaped) curve. Large filter cutoffs average so much of the data curve that pea
corresponding to specific features are unrecognizable. On the other hand, if the filter cutoff is
small, the filtered curve may appear noisy.

The Correlation Curve portion of the histogram presents a lowpass, Gaussian-filtered version
the raw data. The low-pass Gaussian filter removes noise from the data curve and averages
curve’s profile. Peaks which are visible in the curve correspond to features in the image at dif
widths.

Peaks do not show on the correlation curve as discrete, isolated spikes; instead, peaks are 
contiguous with lower and higher regions of the sample, and with other peaks. This reflects t
reality that features do not all start and end at discrete depths. 

When using the Width  View for analysis, each peak on the filtered histogram is measured from
statistical centroid (i.e., its statistical center of mass). 

Using the Grid Display

Measurement cursors for histogram are automatically positioned based on the numerical val
selected in the Input  fields. Right-clicking on the grid will bring up the Grid Parameters menu 
(see Figure 4.9b) and allow you to make the following changes:
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Figure 4.9b   Grid Parameters Menu

Color Allows operator to change the color of the:

• Curve (data)

• Text

• Background

• Grid

• Minor Grid

• Markers

Filter Typically used for a Profiler Scan.

• Type—Select None, Mean (default), Maximum, or Minimum

• Points—Select 4k, 8k (default), 16k, or 32k

Minor Grid Places a minor grid in the background of the Vision window.

Scale Allows user to auto scale, set a curve mean, or set their own data 
range

Line Style For each curve, the operator can choose a connect, fill down, or point 
line.

User Preferences Restore—Reverts to initial software settings

Save—Saves all changes operator has made during this session. This 
becomes the new default settings.

Copy Clipboard Copies the grid image to the Microsoft Clipboard

Print Prints out the current screen view to a printer

Export Exports data in bitmap, JPEG or XZ data format

Active Curve Determines which curve you are analyzing
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4.9.2 Width Procedures

1. If no workspace is present, open a new workspace (File > New Workspace).

2. Open the image you wish to analyze (File > Open > Captured Data File) or double click on 
the browse view image. 

3. In the workspace, position the cursor on the file name and right-click to access a funct
pop-up menu.

Figure 4.9c   Functions Menu

4. In the pop-up menu, select Add View > Width .

5. You can view the Width View using one of the following methods:

• Right-click on the image name in the Workspace and select Add View > Widt h from 
the popup menu.

                                     Or

• Select Analyze > Width  from the menu bar.

                                     Or

• Click the Width  icon in the upper toolbar. 

6. Using the mouse, left-click and drag a box on the area of the image to analyze. 
The Histogram displays the depth correlation on this specified area.

Note: If no box is drawn, by default, the entire image is selected.

7. Adjust the Minimum Peak to Peak to exclude non relevant depths.

8. Adjust the Histogram Filter Cutoff  parameter to filter noise in the histogram as desired.
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Note: To save or print the data, run the analysis in an Auto Program 
(see Section 4.11).

Figure 4.9d   Width Interface

4.9.3 Width Interface

The Widt h interface includes a captured image, Input  parameters, Results parameters and a 
correlation histogram, shown in Figure 4.9e.

Figure 4.9e   Depth Histogram
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Width Input Parameters

The depth input parameters below define the slider cursor placement for determining the exa
depth of a feature.

Threshold Plane The z height which is used as a minimum for the higher peak. This ca
adjusted by moving the cursor in the correlation histogram.

Number of Histogram Bins The number of data points, ranging from 4 to 512, which result from th
tering calculation.

Histogram Filter Cutoff Lowpass filter which smooths out the data by removing wavelength co
nents below the cutoff. Use to reduce noise in the Correlation histogra

Min Peak To Peak Sets the minimum distance between the maximum peak and the seco
peak marked by a cursor. The second peak is the next largest peak to
this distance criteria.

Lowest Peak The left (smaller in depth value) of the two peaks chosen by the curso
Value used to define how much of the left peak is included when calcul
the centroid. At 0 percent, only the maximum point on the curve is 
included. At 25 percent, only the maximum 25 percent of the peak is 
included in the calculation of the centroid. 

Highest Peak The right (larger in depth value) of the two peaks marked by the curso
Value used to define how much of the right peak is included when calc
ing the centroid. At 0 percent, only the maximum point on the curve is
included. At 25 percent, only the maximum 25 percent of the peak is 
included in the calculation of the centroid.

Reference You may specify a reference point for the cursor. This feature is usefu
repeated, identical measurements on similar samples. After moving th
sor to a specific point on the correlation histogram, that point is saved
distance from whatever reference peak you choose. These reference 
include: HIGHEST PEAK , LOWEST PEAK , MIN PEAK  and MAX PEAK .

Distance from peak Cursor distance from the REFERENCE peak

Percent peak to peak Cursor position/(peak-to-peak distance)
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Results Parameters:

4.10 XY Drift

Due to temperature differences, thermal lateral drift can occur between two successive imag
while scanning. Using Offline XY Drift  analysis, the software can calculate the lateral shift 
between two images. You can also manually enter the drift.

4.10.1 Realtime XY Drift

You can capture two images in Realtime mode for later XY Drift  analysis in Offline mode. 

1. You must be in Realtime mode and engaged (Realtime > Engage).

2. Select Realtime > XY Drift . The XY Drift Control  dialog box displays (see Figure 4.10a).

Figure 4.10a   XY Drift Control Dialog Box

3. Enter the appropriate capture calibration settings and select Calibrate. Two images are 
captured with the number of lines designated, then the Offline XY Drift View  opens (see 
Offline XY Drift Analysis:   Section 4.10.2).

Note: Both images must have the same microscope configuration and scanner 
calibration settings currently in use.

X mean The average of the highlighted X values within the enclosed area.

X sigma The standard deviation of the measured X values.

Y mean The average of the highlighted Y values within the enclosed area.

Y sigma The standard deviation of the measured Y values.

Area The area below the threshold in the selected region.
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Calibration Capture Settings

XY Drift Control Dialog Box Buttons

Down Frame
Captures lines from the top of the image to the bottom.

Up Frame
Captures lines from the bottom of the image to the top.

Number of Lines Designates the number of lines to capture. This number must be less than
or equal to the Lines parameter in the Scan View > Scan tab panel.

Skip Frames Designates the number of frames to skip at the beginning of the scan.

X Correction Reports the current X correction value.

Y Correction Reports the current Y correction value.

Calibrate Stops any current drift correction and captures 2 images. After capturing 
the images, the Offline XY Drift  View automatically displays.

Quit Closes the XY Drift Control  dialog box.

Stop Drift Correction Stops any current drift correction.
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4.10.2 Offline XY Drift Analysis

Requirements

Two images from the same capture directory captured within 1 day of each other are require
capture direction must be the same for both images (up or down), and the images must have
same microscope configuration and scanner calibration properties.

Procedure

To calculate XY Drift using the software:

1. Start with the earliest image and use one of the following methods to open the XY Drift 
Analysis View (see Figure 4.10b).

• Right-click on the image name in the Workspace and select Add View > XY Drift 
from the popup menu.

                                     Or

• Select Analyze > XY Drift  from the menu bar.

                                     Or

• Click the XY Drift  icon in the upper toolbar. 
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Figure 4.10b   XY Drift View

2. Use the Load Image button to browse for the subsequent image.

3. Click the Calculate Shift button. The software will calculate the shift of the second imag
relative to the first image.

4. The results display in the Results box. 

a. To apply the corrections in the Inputs box, click the Apply  Correction button.

                                                             Or

b. You can also manually enter the correction values in the Inputs box. Click the Apply  
Correction button.

Note: Apply Correction effects Realtime by applying a drift correction to the 
Realtime images. Do not use Apply Correction if this is not your intent.
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Statistics used by the XY Drift  analysis are defined in this section. 

Results Parameters

Results of the XY Drift  analysis are presented in this section.

XY Drift Buttons

Number of scan lines Specifies the number of lines to calculate.

Flatten Flattens both images before the shift is calculated. (Use the Undo Flatten 
button to reverse the flatten).

X Correction Specifies the amount of correction to apply to the X-axis of the scanner.

Y Correction Specifies the amount of correction to apply to the Y-axis of the scanner.

Second Image Defines the location of the second image used in the analysis.

X Shift Specifies the amount of calculated shift along the X-axis of the second 
image relative to the first.

Y Shift Specifies the amount of calculated shift along the Y-axis of the second 
image relative to the first.

Tested Correlation
Coefficient

Reports the correlation coefficient after correcting for the detected shift. A 
perfect correlation is 1.0. If the tested correlation coefficient is too low, 
then the calculation is not valid and should not be applied. You may need 
features that have more distinct contrast.

Raw Correlation
Coefficient

Reports the correlation coefficient between the two images prior to pro-
cessing.

Load Image Browse to open the second image in the right box.

Calculate Shift Compares left image to right image, and reports the shift statistics in the 
Results box.

Apply Correction Applies the correction in the Inputs box to the second image.

Undo Flatten Undo Flatten restores the image to its original form.
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4.11 Multiple Channel Analysis

It is often necessary to analyze more than one channel of data from the same scan. This can
by opening a captured dual-scan or triple-scan image Offline. 

4.11.1 Dual-Scan Image

When you open a dual-scan image, the Channel 1 and Channel 2 images will appear side by side,
with Channel 1 on the left and Channel 2 on the right, and the channel data will typically be 
shown below the left image. Click on the desired image to select the channel and the corresp
channel data will appear (see Figure 4.11a).

Note: The location of the Channel data may vary depending on window proportio

Figure 4.11a   Captured Dual-Scan Image
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4.11.2 Triple-Scan Image

When you open a triple-scan image, the Channel 1 and Channel 2 images will typically appear 
side by side, with Channel 1 on the left and Channel 2 on the right, and the Channel 3 image will 
typically appear below the Channel 1 image. Channel data is now shown to the right of the 
Channel 3 image. Click on the desired image to select the channel and the corresponding ch
data will appear (see Figure 4.11b).

Note: The location of the Channel data may vary depending on window proportio

Figure 4.11b   Captured Triple-Scan Image

4.11.3 Analyzing Captured Multichannel Images

When performing any analysis of a multichannel scan, you may only analyze one channel at a
Highlight the appropriate channel image by clicking on it, then select the desired Analysis View by 
any one of the following:

• Right-clicking on the image file name in the Workspace, selecting Add View, and 
clicking on the desired view.

• Selecting Analyze from the menu bar and clicking on the desired view.

• Clicking on the appropriate button in the button bar.
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Once you select the desired channel, and the appropriate view, a new window will open with
the image of the selected channel and you may start your analysis in accordance with the 
instructions in Section 4.1 through Section 4.3. If the image display in the view is not the desired
channel, you can right-click on the image, go to Channel, and select the appropriate channel from
the pop-up menu.

You can also print multichannel images simultaneously. All channels must be open in the sam
view, then select File > Print .

4.12 AutoProgram

An AutoProgram is a sequence of operations that may be applied automatically to at least one
previously captured image. Typically, an AutoProgram is created to rapidly analyze a large nu
of images taken under similar conditions. Any image Modify  or Analyze command may be 
included in an AutoProgram. Do the following to create an AutoProgram:

1. Select a directory, then an image file within it, from the file browsing window at the righ
the NanoScope main window. Double-click its thumbnail to select and open the image. T
image file name and the Offline  icon, as well as a sunburst icon and the word “Image” are 
added to the Workspace, and the image opens in the viewing window (see Figure 4.12a).

Figure 4.12a   Open Image
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2. In the Workspace, right-click on the image file name or its Offline  icon and select Create 
AutoProgram (see Figure 4.12b).

Figure 4.12b   Create AutoProgram

3. You are asked if you want to include the selected image to define the AutoProgram am
the images processed by the AutoProgram (see Figure 4.12c). (Typically: “Yes.”) The Add 
Linked  box should also be checked. When linking, any changes made to the currently a
view will then alter any linked views.

Figure 4.12c   Include Selected Image Box

4. In the AutoProgram Results View (see Figure 4.12d):

a. Right-click on Autoprogram , under the file name or icon appearing on the line unde
Run Group. 

b. Click Add View to add a view to the Autoprogram. This view will then be added to 
files in the Autoprogram if they are linked.
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c. Click the view of an Analyze or Modify  command to be performed first by the 
AutoProgram. 

d. Repeat for additional views (in Figure 4.12a, Flatten, Depth then Roughness 
operations will be performed).

Note: Example specifications of the Flatten, Depth and Roughness commands for 
inclusion in an AutoProgram are described next. Similar actions apply to 
include other Offline Analyze and Modify  commands in an AutoProgram.

Figure 4.12d   Add Views to be Included in an AutoProgram

4.12.1 Example command: Flatten

To open the Flatten View: 

1. Click the command name or icon that has been added to the Run Group Autoprogram. 

2. Click in the image and drag open a box over features in the image that are to be exclu
from the polynomial fit calculations (see Figure 4.12e). Typically, only featureless areas are
used for flattening an image. 
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3. On the right of the Flatten View, set parameter values to apply for all images operated on
the AutoProgram. 

4. Close the Flatten View.

4.12.2 Example command: Depth 

To open the Depth View: 

1. Click the command name or icon that has been added to the Run Group Autoprogram. 

2. Click in the image and drag open a box over an area that contains a height step (see Figure 
4.12g). 

3. On the right of the Depth View, set parameter values that will apply for all images operat
on by the AutoProgram. 

4. Close the Depth View.

Figure 4.12e   Specify a Flatten Operation
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4.12.3 Example command: Roughness

To open the Roughness View: 

1. Click the command name or icon that has been added to the Run Group Autoprogram. 

2. Click in the image and drag open a box over an area where you would like the sample s
condition analyzed (see Figure 4.12g). 

3. On the upper right of the Roughness View, set parameter values that will apply for all 
images operated on by the AutoProgram. 

4. On the lower right of the Roughness View, select what measurements to report. 

5. Close the Roughness View.

Figure 4.12g   Specify a Roughness Measurement for Inclusion in an AutoProgram
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4.12.4 Running AutoProgram

Once all commands are included in the AutoProgram list and their action specified, you are re
run AutoProgram.

1. Click the Add Files button in the AutoProgram Results View (see Figure 4.12h). The Add 
Files dialog box appears.

2. In the Add Files dialog box, select the Link Files box to have the same AutoProgram 
instructions apply to each file. Select files of interest and click Add to have the selected files
included when the AutoProgram is run. Hold down the Shift key to select a consecutive 
group of files or the Control  key to select more than one individual file.

3. In the AutoProgram Results View, check the Hide View box if you don’t want the images 
displayed, as they are automatically analyzed by the AutoProgram. If you want to see the 
images processed during AutoProgram execution, leave Hide View unchecked. Increasing 
the value in Computation Time allows more time to view operations during Autoprogram
execution.

Figure 4.12h   Add Files Dialog Box
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4. Click the Run button in the AutoProgram Results View to start the AutoProgram.

Note: The RUN button toggles to display Stop while the AutoProgram is running. 
Click it if you need to stop the process before it is completed. Clicking the Run 
button again restarts the AutoProgram at the first image.

5. Upon completion, the data appears in the Log File View property sheet (see Figure 4.12i).

Figure 4.12i   Log File View Property Sheet

6. If you close the Autoprogram  Results View without saving the Autoprogram, you will be 
prompted to save the Autoprogram as an .apg file.

7. To save the log file, select the SAVE LOG button in the Log File View.

8. To clear the log file, select the CLEAR  LOG button in the Log File View.

9. Autoprogram results, with statistical analysis (termed reports), can be printed or export
tab delimited text using the PRINT  REPORT or EXPORT REPORT buttons.

Print Report

Export Report Clear Log

Save Log
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The Modify  commands are in the lower portion of the Analyze menu. Analyze appears in the menu 
bar once an image is open/active. It also appears in the Add View submenu and is accessible with a
right-click on the image name in the workspace. Modify  commands are used to eliminate noise, 
and correct for bow and tilt. These operations process the captured/stored image, then produ
another (modified) version.

Please refer to the following analysis commands available on the NanoScope software:

• Flatten: Section 5.1

• Plane Fit: Section 5.2

• Lowpass Section 5.3

• Erase: Section 5.4

• Median: Section 5.5
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5.1 Flatten

The Flatten command eliminates unwanted features from scan lines (e.g., noise, bow and tilt
uses all unmasked portions of scan lines to calculate individual least-square fit polynomials f
each line. 

Flatten is useful prior to image analysis commands (e.g., Depth, Roughness, Section, etc.) where 
the image displays a tilt, bow or low frequency noise, which appear as horizontal shifts or strip
the image. 

Figure 5.1a   Image Flattened

Bow in Image

Bow Removed
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5.1.1 Flatten Theory

The Flatten command is a filter that modifies the data to delete low frequency noise and remo
from an image. Each line is fit individually to center data (0th order) and remove tilt (1st orde
2nd or 3rd order bow. A best fit polynomial of the specified order is calculated from each data
and then subtracted out. In some cases, the stopband (box cursor to exclude features) can b
remove regions of the image from the data set used for the polynomial fits. Click on the imag
start drawing a stopband box. Right-click on a box to delete it or change its color. 

Flatten Polynomials

The polynomial equations calculate the offset and slope, and higher order bow of each line f
data (see Table 5.1a).

Table 5.1a   Flatten Polynomials

Order Polynomial Explanation

0 z = a Centers data along each line.

1 z = a + bx Centers data and removes tilt on each 
line [i.e., calculates and removes off-
set (a) and slope (bx).

2 z = a + bx + cx2 Centers data and removes the tilt and 
bow in each scan line, by calculating 
a second order, least-squares fit for 
the selected segment then subtracting 
it from the scan line.

3 z = a + bx + cx2 + dx3 Centers data and removes the tilt and 
bow in each scan line, by calculating 
a third order, least-squares fit for the 
selected segment then subtracting it 
from the scan line.
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5.1.2 Flatten Procedures

For an image that contains a number of noisy scan lines, use the Flatten command to correct the 
problem.

1. Open the image. Note disjointed scan lines which are misaligned along the Z-axis (som
high and some are low). This effect somewhat resembles an unshuffled deck of cards 
viewed on-edge or appears as horizontal streaks or bands. The image may have bow a
Y-axis. 

Figure 5.1b shows an image file in its original, raw form as an example for the Flatten command. 
Many of the image’s scan lines are disjointed along the Z-axis. 

Figure 5.1b   Raw Image of Syndiatatic Polystyrene (500nm)

Top View of Image to Flatten                                         Surface Plot of Image showing Bow
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2. You can view the Flatten View using one of the following methods:

• Right-click on the image name in the Workspace and select Add View > Flatten from 
the popup menu.

                                     Or

• Select Analyze > Flatten from the menu bar.

                                     Or

• Click the Flatten icon in the upper toolbar. 

3. Set the Flatten order value to 0. This removes the scan line misalignment.

4. Click on Execute to initiate the Flatten command. The flattened image appears on the 
display screen.

Note: Figure 5.1c shows the same image file after using a zero-order Flatten (Flatten 
order = 0). The scan lines are now aligned.

Figure 5.1c   Flattened Image of Syndiatatic Polystyrene (500 nm)

5. To see a variety of effects using the Flatten command, enter different Flatten order values. 
Each new change may be undone by clicking on the Reload button.

Top View of Flattened Image Surface Plot View of Flattened Image
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5.1.3 Flatten View Interface

Click Analyze in the menu bar and select Flatten, or click on the Flatten icon in the button bar. A 
series of parameters appear in the Flatten View, allowing the order of the equation to be selected
and display parameters to be adjusted to your preference.

Figure 5.1d   Flatten View
0 Nanoscope 6.13 User Guide Rev. D
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 Input Parameters:

Flatten Order 

Flatten Order selects the order of the polynomial calculated and subtracted from each scan 

Range and Settings:

Buttons on the Flatten Panel 

Flatten Order Flatten Order selects the order of the polynomial calculated and sub-
tracted from each scan line.

Range and Settings:

• Zero Order (0)—Removes the Z offset between scan lines by sub-
tracting the average Z value for the unmasked segment from every 
point in the scan line.

• First Order (1)—Removes the Z offset between scan lines, and the 
tilt in each scan line, by calculating a first order, least-squares fit for the 
unmasked segment then subtracting it from the scan line.

• Second order (2)—Removes the Z offset between scan lines, and the 
tilt and bow in each scan line, by calculating a second order, least-
squares fit for the unmasked segment then subtracting it from the scan 
line.

• Third order (3) —Removes the Z offset between scan lines, and the 
tilt and bow in each scan line, by calculating a third order, least-squares 
fit for the unmasked segment then subtracting it from the scan line.

Flatten Z Thresholding 
Direction

Specifies the range of data to be used for the polynomial calculation 
based on the distribution of the data in Z:

Range or Settings:

• Use Z >= —Uses the data whose Z values are greater than or equal to
the value specified by the Z thresholding %.

• Use Z <—Uses the data whose Z values are less than the value speci
fied by  the Z thresholding %.

• No thresholding—Disables all thresholding parameters.

Flatten Threshold for Applies the Thresholding values for the whole image or each line inde-
pendently.

Range or Settings:

• The whole image

• Each line

Flatten Z Threshold % Defines a Z value as a percentage of the entire Z range in the image (o
data set) relative to the lowest data point.

Execute Initiates the command, based on the order selected.

Reload Restores the image to its original form.
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5.2 Plane Fit

The Plane Fit command calculates a single polynomial of a selectable order for an image and
subtracts it from the image. The Plane Fit operation can be applied to either or both of the XY 
directions.

Box cursors, or passbands, allow specific points to be used in the calculation of the polynom
Click on the image to start drawing a passband box. Right-click on a box to delete it or chang
color.

Figure 5.2a illustrates an image with tilt and bow which could affect the analysis of the surface
data.

Figure 5.2a   Visual Representation of Plane Fit

                                    

Tilt of Sample Surface 3rd Order Plane Fit
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5.2.1 Fitted Polynomials

Refer to Table 5.2a to view the polynomials that calculate the best plane fit for the images in th
Plane Fit Auto function.

Table 5.2a   Plane Fit Auto Equations

Order Variable Polynomial Equation

0 X z = a

Y z = a

XY (Add Higher Order Cross 
Terms for XY OFF)

z = a

XY (Add Higher Order Cross 
Terms for XY ON)

z = a

1 X z = a + bx

Y z = a + by

XY (Add Higher Order Cross 
Terms for XY OFF)

z = a + bx + cy

XY (Add Higher Order Cross 
Terms for XY ON)

z = a + bx + cy + dxy

2 X z = a + bx + cx2 

Y z = a + by + cy2

XY (Add Higher Order Cross 
Terms for XY OFF)

z = a + bx + cy + dxy + ex2 + fy2

XY (Add Higher Order Cross 
Terms for XY ON)

z = a + bx + cy + dxy + ex2  + fy2+ gxy2 + hx2y + 

ix2y2

3 X z = a + bx + cx2 + dx3

Y z = a + by + cy2 + dy3 

XY (Add Higher Order Cross 
Terms for XY OFF)

z = a+ bx + cy + dxy + ex2 + fy2 + gxy2 + hx2y + 

jx3 + ky3

XY (Add Higher Order Cross 
Terms for XY ON)

z = a + bx + cy + dxy + ex2 + fy2+ gxy2 + hx2y + 

ix2y2 + jx3 + ky3 + lxy3 + mx2y3 +nx3y3 +ox3y + 

px3y2
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5.2.2 Plane Fit Procedures

Use Plane Fit to correct the image distortion as follows:

1. Open an image file from the menu bar (File > Open > Image) or through Browse (View > 
Browse), then double click on the image.

2. You can view the Plane Fit View using one of the following methods:

• Right-click on the image name in the Workspace and select Add View > Plane Fit 
from the popup menu.

                                     Or

• Select Analyze > Plane Fit from the menu bar.

                                     Or

• Click the Plane Fit icon in the upper toolbar. 

Note: The Plane Fit input parameters appear along with the top view image. 

3. Select X, Y, or XY .

4. Select the Order .

5. Select Execute.

6. Notice that the image distortion is removed, reflecting a flat, planar profile. 

Figure 5.2b   Saddle Image Before Plane Fit
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Figure 5.2c   Plane Fit View

Figure 5.2d   Plane Fit Image
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Now, experiment with this image to explore the range of Plane Fit  capabilities. Try the following:

• Change the Planefit order value to see its effects. Notice that there is a vast differen
between a value of 1, 2 or 3.

• Try plane fitting in one axis (for example, X), but not the other. This generally keep
whatever distortions are presently oriented along the unused axis. For example, th
image can be straightened along its Y axis, while leaving the X axis strongly bowe

• Try using a different Planefit order for the X and Y axis (for example, a setting of 3 for 
X, but a setting of 1 for Y.) This is similar to using one axis, but not the other.

• Compare the effect of Plane Fit with Flatten. Notice that each command has a 
significantly different impact upon this image; although, the difference is less notice
for some other types of images.
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5.2.3 Plane Fit Interface

The Plane Fit dialog box (see Figure 5.2e) allows the display parameters and the Planefit order 
be adjusted to your preferences. 

Figure 5.2e   Plane Fit Inputs Dialog Box
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 Buttons on the Plane Fit Window:

Input Parameters:

Execute  Initiates the plane fit operation.

Reload Restores the image to its original form.

Planefit order Selects the order of the plane calculated and subtracted from the image.

Z Thresholding direc-
tion

Specifies the range of data to be used for the polynomial calculation based on 
the distribution of the data in Z:

Range or Settings:

• Use Z > = —Uses the data whose Z values are greater than or equal to the 
value specified by  the Z thresholding %.

• Use Z <—Uses the data whose Z values are less than or equal to the value 
specified by  the Z thresholding %.

• No Thresholding—Disables all thresholding parameters.

Z Thresholding Per-
cent

Defines a Z value as a percentage of the entire Z range in the image (or data 
set) relative to the lowest data point.

Add Higher Order 
Cross Terms

Turning this on adds higher order cross terms to the polynomial fit when XY 
is chosen (see Table 5.2a).
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5.3 Lowpass

The Lowpass modify command applies spatial filtering to a captured image, suppressing high
spatial frequency components. Each pixel in an image is replaced with the average value of 
3 × 3 pixels centered on it.

1. Select an image file from the file browsing window at the right of the main window. Dou
click the thumbnail image to select and open the image.

2. You can view the Lowpass View (see Figure 5.3a) using one of the following methods:

• Right-click on the image name in the Workspace and select Add View > Lowpass from 
the popup menu.

                                     Or

• Select Analyze > Lowpass from the menu bar.

                                     Or

• Click the Lowpass icon in the upper toolbar. 

Figure 5.3a   Lowpass Image Display

3. Click the Execute button in the Lowpass window to apply the low pass function to the cop
of the image in both windows.

4. To restore the unprocessed image, click the Reload button.

Note: There are no parameter controls for the Lowpass modify command.
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5.4 Erase

The Erase modify command is a retouching function for editing images. Previously, horizonta
lines could be replaced with an interpolation from the adjacent lines. In Version 6, the capabi
extended to rectangular areas as well.

1. Select an image file from the file browsing window at the right of the main window. Dou
click the thumbnail image to select and open the image.

2. Open the Erase View (see Figure 5.4a) using one of the following methods:

• From the menu bar, click Analyze > Erase.

                                     Or

• Right-click on the Image file name in the Workspace and select Add View > Erase 
from the menu.

                                     Or

• Click the Erase icon in the upper toolbar. 

Figure 5.4a   The Erase Option in the Analyze Menu
0 Nanoscope 6.13 User Guide Rev. D



Modify Commands
Erase

y the 

e.

e to 
3. A separate window opens, also displaying the image. Right-click in the image to displa
Erase options menu (see Figure 5.4b). Select either Horizontal Line  or Area and a check 
mark will appear. The option chosen will remain checked until another selection is mad

4. Click anywhere within the image to define a horizontal line, or click and drag in the imag
define a box to be replaced.

Figure 5.4b   Erase Options Menu
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5. Click the Execute button to perform the interpolation.

Figure 5.4c   Effect of the Erase Interpolation on a Rectangular Area

6. Right-click on an Erase feature of a modified image (either line or box) for options to 
complete the operation. Click Delete to erase the dashed construction lines from the displ
of the selected feature. Click Clear All  to eliminate all construction lines from the display, 
while retaining the modifications to the image.

7. To eliminate all trace of Erase activity to an image, click the Reload button while the image 
is still open in the Erase panel.

Before After
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5.5 Median

The Median modify command is similar to Lowpass; it reduces the contributions of high spatial 
frequency, reducing contrast in regions of high contrast. For each pixel in an image, Median 
substitutes with the median pixel value of the n×n array of pixels centered around that pixel. The
size of the filter’s sliding window pixel array is set under Inputs > Median order. Figure 5.5b 
illustrates the effect of three different size pixel arrays applied to the same image.

Figure 5.5a   # Different Pixel Arrays of the Same Image
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1. Select an image file from the file browsing window at the right of the main window. Dou
click the thumbnail image to select and open the image.

2. Open the Median View using one of the following methods to open a separate window 
which also displays the image (see Figure 5.5b):

• From the menu bar, click Analyze > Median.

                                     Or

• Right-click on the Image file name in the Workspace and select Add View > Median 
from the menu.

                                     Or

• Select the Median icon. 

3. Select the Median Order from the Inputs menu: 3×3, 5×5, 7×7, 9x9, or 11×11.

4. Click Execute to apply the Median filter.

5. Click Reload to start over.

Figure 5.5b   Median View
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Chapter 6   Tools
The Tools commands are in the right portion of the menu bar. 

Please refer to the following analysis commands available on the NanoScope software:

• Options: Section 6.1

• Programmed Move (Dimension Series Only): Section 6.2
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6.1 Options

6.1.1 Remove File on Close

Select Tools > Options > Remove File on Close menu item (see Figure 6.1a). You can also right-
click the workspace and select Remove File on Close. When selected, this option removes the 
workspace item of the offline file when all views on that file are closed.

Figure 6.1a   Remove File on Close Menu Item

Note: The entire Tools > Options menu, with the exception of Set Help File..., is 
available when you right click in the workspace (not on a node).
6 Nanoscope 6.13 User Guide Rev. D



Tools
Programmed Move (Dimension Series Only)

r, then 
uence, 
 runs 
6.2 Programmed Move (Dimension Series Only)

 The Stage > Programmed Move function allows the stage to be automatically positioned at a 
series of memorized positions. These positions are programmed into the controller’s compute
called out automatically in sequence. The operator may run either the entire memorized seq
or skip positions, as desired. This function is particularly useful for statistical quality assurance
on large numbers of identical samples, and as a basic inspection aid.

Refer to the following sections:

• Programmed Move Panels Section 6.2.1

• Procedure for Teaching a Programmed Move Section 6.2.2

• Procedure to Remove a Programmed Option Section 6.2.3

• Procedure to Insert a Step into an Existing Program Sequence Section 6.2.4

• Procedure To Run a Series of Programmed Moves Section 6.2.5
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6.2.1 Programmed Move Panels

To access this option, select on Stage > Programmed Move, shown in Figure 6.2a. 

Figure 6.2a   Selecting Programmed Move

You will be prompted for a new file name or an existing file:

Figure 6.2b   Programmed Move File Name Selection
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After clicking OK , the main Programmed Move panel, shown in Figure 6.2c, will appear:

Figure 6.2c   Programmed Move Window

Definitions 

• Program Name Field—Provides the name of the move program currently loaded (in
this example, the program is called “move”). Moves are first programmed using the
ADD and REMOVE  STEP functions. Later they may be executed using the Run option.

• QUIT  (button)—Exits the Programmed Move panel.

• RUN (button)—Executes the specified program name.
Once a program sequence has been taught to the computer, the program can be ru
the Programmed Move panel. The stage will move to each position in the same orde
was taught, relative to the current origin point. At each program position, the samp
will be scanned for 1.5 frames, captured, then indexed to the next position. Captur
data from each position is stored on the hard disk; there should be sufficient memo
record 100 frames at 256 samples each.

• Origin Points—Current origin at the time of programming.
Programmed Move positions are memorized relative to the current origin at the time of 
programming. If the origin has been shifted from its original position since the time 
programming, it will be necessary to reestablish the original origin point to locate t
same positions on the sample. When generating maps of programmed moves, the
point should always be indicated.
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6.2.2 Procedure for Teaching a Programmed Move

To program (teach) a series of moves, do the following:

1. Select a file name for a new or existing Programmed Move file. See Figure 6.2b.

2. Click OK  to proceed with programming moves. A new panel, shown in Figure 6.2c, will be 
displayed.

3. Make a stage move using either the trackball or the Move To X,Y panel (i.e. enter X and Y 
POSITION  or POSition CHANGE  and click MOVE).

4. Click ADD STEP.

5. This procedure may be repeated until all the desired positions have been programmed 
maximum of 100 steps. Each position will be automatically assigned a program step nu

It may prove helpful to draw a simple map of the sample, along with each programmed posit
before programmed moves are entered. If reducing cycle time is important, position order sh
be optimized to reduce stage travel. Also, note the origin point at the time of programming.

6. When all stage positions have been entered into the program, click SAVE PROGRAM , then 
QUIT .

7. Additional programs are entered in the same manner, using a separate program name
each.

6.2.3 Procedure to Remove a Programmed Option

To remove a step from the programmed sequence:

1. Select a file name for an existing Programmed Move file. See Figure 6.2b.

2. Click OK  to proceed with programming moves. A new panel, shown in Figure 6.2c, will be 
displayed.

3. Click in the Step # field in the Select Step sub-panel.

4.  Enter the step number to be removed into the keyboard, or drag the mouse to index to
step number. The stage will simultaneously move to the new step position.

5. Click the REMOVE  STEP button. When individual program steps are removed, all subsequ
steps are “moved up” by one count. (For example, after removing step #2 from a progr
step #3 would become the new step #2, step #4 would become the new step #3, etc.)

6.  Click the SAVE PROGRAM  button to save the edited version of program.
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6.2.4 Procedure to Insert a Step into an Existing Program Sequence

1. Select a file name for an existing Programmed Move file. See Figure 6.2b.

2. Click OK  to proceed with programming moves. A new panel, shown in Figure 6.2c, will be 
displayed.

3. Click in the STEP # field in the Select Step sub-panel.

4. Enter one less than the step number to be added to the sequence, or drag the mouse to
to the desired step number. (For example, if the operator wishes to add a new program
#7, while leaving all preexisting steps intact, they would enter “6” in the STEP # field. The 
stage will simultaneously move to the preexisting step position #6.)

5. Make a stage move using either the trackball or the Move To X,Y panel (i.e. enter X and Y 
POSITION  or POSITION  CHANGE  and click MOVE).

6. When new program steps are added, all preexisting steps beyond the new entry are “m
up” by one count.

7. Click SAVE PROGRAM  to save the edited version of program.

6.2.5 Procedure To Run a Series of Programmed Moves

1. Select a file name for an existing Programmed Move file. See Figure 6.2b.

2. Click on OK  to proceed with programming moves. A new panel, shown in Figure 6.2c, will 
be displayed.

3. Click the RUN button. If the program is being loaded and run from the beginning, the sc
will prompt the operator whether to refocus the screen:

Figure 6.2d   Stage Panel

4. Clicking on Yes will transfer the user to the Focus Surface panel; the user may then make 
focusing adjustments to better view the surface. Clicking on No will initiate the programmed 
move from step #1.

If the program was previously run without finishing (aborted), the screen will request whether
begin the program sequence at the aborted step; for example, if the operator left off at step #
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Figure 6.2e   Stage Panel

5. The operator may wish to run the entire program from its beginning (step #1); if this is 
case, click No. Otherwise, click Yes. The screen will display the current program step in 
progress:

Figure 6.2f   Programmed Move Panel
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